Video codec, bitrate columns don't show anything except WMV

DOpus v9.0.0.8

My DOpus does not show any video information columns, e.g. codec, bitrate, frame rate, etc. for any video files but WMV; MP3 info columns are shown also correctly. I've K-Lite Codec Pack Full installed and AVIs, MP3s, MPGs are played just fine in Media Player Classic and DOpus (see attached file). I've checked the following threads and then my DOpus settings and registry, but everything seems to be OK; PerceivedType, Mime, GSpot info are all fine.

[url]Audio and Video Codec data doesnt display in lister movie fo]
[url]HOW TO: Enable/fix playback of various media formats in Opus]

Any idea why DOpus doesn't show the info?

Can you upload one of the AVIs so we can try it?

Thanks for the lightning fast reply :open_mouth:

Please see the attachment. I've picked up a very small file with no audio in order not to waste much space, but I can upload a bigger one if you like.
brautstrauss.rar (75.7 KB)

This file seems ok to me.

Perhaps it's your codecs? I know codec packs are meant to have lots of problems. I just use ffdshow - it plays just about everything these days.

I think I've isolated the problem a bit more. It has nothing to do with the codecs, but with WMP7+.

Case 1:
Under VMware, with a fresh default Windows and DOpus installation, DOpus shows the properties.

However, when I uninstall WMP7 and Skins, but not the codecs nor WMP6, via XPlite, DOpus stops showing the information. Even if I install ffdshow (the latest build from, Sourceforge files are not updated), DOpus does not show the codec information. I've configured ffdshow so that it decodes everything. Needless to say, the files are played fine.

Case 2:
Very similar. My main computer is installed from an nLite-customized ISO. It does not have WMP7 either. As far as I, no, Gspot can tell the codec configurations are OK. DOpus shows on this PC no metainfo either.

Both K-Lite and GSpot are able to detect broken configs. So I guess, this problem has nothing to do with codec packs nor my codec configuration on my main PC, but WMP.

Does this info help you?

Forgot to mention the Windows versions.

The VM is a WinXP SP1, and my main PC is a WinXP SP2.

I've experimented a bit more. After re-installing WMP7 via XPlite, DOpus shows the metainfo back again.

I have a diff-file of registry, showing the states before and after the installation. If this could help you, I can send it but please contact me privately, I don't want to upload it publicly. The diff's big though, 933K of additional text :open_mouth: No surprise that I banned WMP off my PC. I can even send you a complete export of the registry files, they're each about 1M compressed.

I'm not sure, but since it seems like the problem can be solved by installing ffdshow, it seems to me that it's not really an Opus issue but something to do with the codecs. Or am I misunderstanding?

Yes, I think there's a misunderstanding. If WMP7 is not installed nothing is shown; with or without ffdshow, ffdshow has simply no effect. When WMP7 is not installed, Explorer does not show any metainfo in "Properties" and all the exta columns in detail view are gone too. So it seems WMP7 handles all the codec-info and columns, not the codecs.

So install WMP? Problem solved :slight_smile:

I was afraid, that you'd say that :confused:

Nah, I think, this functionality is not that important to me, that I'd clutter my PC with WMP: 7364 extra lines in the diff file, i.e. registry and lots of , for a program which I never ever use. But hey, at least we've found out what the problem is, right? :smiley:

I'll try to isolate the responsible dll's with regmon/filemon, let's see what I'll find.

WMP can't be ignored these days so you are going to need it in one way or another. As you have seen, you'll loose some functionality (and not only that) in Windows without it.

I also use customed Windows ISO's and I've succcessfully integrated latest WMP 11 with a slipstreamer.

Well, depends. I can ignore it and I did actually :slight_smile: I don't know what else one loses except this metainfo-functionality, and I've no DRM-protected media either, so I've decided not to install WMP on my main machine. It's just too headstrong and bloated, I can surely survive without WMP :slight_smile: I've made myself a VM with all the codecs, multimedia programs and such. It works perfect and is much easier to administrate.

I have to look at the needed DLLs & reg-settings yet, maybe I can isolate them, but I don't have time ATM.

It's your computer and your time but I don't understand why it's worth the effort, not to mention the risk of other things not working, just to avoid having a few files and registry settings.

I am no fan of Windows Media Player but just having it installed doesn't mean it gets in the way (I have all the filetypes associated with other programs and only see WMP if I explicitly run it) and it only uses up a few meg of disk space.

Leo, I really don't want this to get a philosophical discussion. But for the records, first I like modifying my OSes (the very same reason why nLite and alike exist) and second there was a time when WMP spied on users. Admittedly, you can opt-out lately but I simply don't like WMP anyway. I don't need it, trust it, use it nor want it. In all these years without WMP, I've not experienced a break and this was the very first problem I've had regarding not having WMP; more to this below.

Anyway, it didn't cross my mind that Dopus' functionality depended on WMP and so I've asked a question which many people on Internet asked as well: "why do the metainfos disappear?"; although noone seems to relate it to WMP and some of those people do have WMP. Indeed, during my testings I've discovered that another extremely lightweight VMware of mine, which also does not have WMP (along with lots of other "supposedly integral" components and services; 193 MB total VM size), can show the metainformation. I have yet to discover, what exactly I did there and which settings are responsible for this. In other words, WMP is not really needed.

I think the article you linked is overreacting. The "spying" when a DVD is inserted is no different to the way most good media players will look up CD track titles on the internet when an audio CD is inserted (which very few people seem to mind and is thus on by default in most programs).

Anyway, I doubt I'll change your mind or vice versa so I'll leave you to it. :slight_smile: