View jumping when scrolling through folder

When I'm scrolling through a folder if I click a file and then scroll the file off screen if I stop the view pops back to the file I had clicked before whether I still have it selected or know. I can't imagine this isn't somewhere on the forums but I don't know what to search for lol. It happens on both my machines that I run Directory Opus on. I'm not sure if this is just a feature I have on or what.

I don't think that's normal, unless the cursor key is pushed after scrolling.

Which display mode are you seeing it in?

How are you scrolling? (Clicking scrollbar, mouse wheel, etc.)

Do you know which mouse drivers you're using?

on both machines I'm using a
Logitech performance mx mouse
using the scroll wheel in indexed mode or free spin; grabbing the bar and moving it, I also experience it when using my wacom Intous 3, with both the touch sensitive scroll areas on the tablet, and holding a pan button and dragging with my pen.
I use Dual Horizontal (portrait monitor) on one machine and Dual Vertical (laptop landscape) on the other machine.
Logitech Software is...
Control Center Version : 6.32.7
Driver Version: 5.33.14

Both Dopus versions are (5080) 64bit

I have also experienced this using my portable license as well.

Same mouse + drivers as me so it can't be that. (Unless the Wacom tablet is involved, but it shouldn't be when the mouse is being used at least.)

The only thing I can think of is that the clicked file is going into rename mode, which a click can trigger and which would scroll the list back to make the file being renamed visible, but any amount of scrolling after the click should cancel the rename if it hasn't started yet (and once it has started you can no longer scroll), so that doesn't seem very likely unless something strange is happening.

If you're seeing it on your portable copy on other machines as well then it might be a particular configuration setting (or combination of settings), but none come to mind so far. (Single-click "point to select" mode could be related, if that's turned on, but I just tried and couldn't get anything similar to happen, so I'm not sure.)

I could try installing a fresh copy of Dopus on a Windows 7 virtual machine I have which is a clean as it gets to see if I can reproduce the issue, but I'm not sure if my License allows that. I can see how it might be something I may have configured as I use the backup and restore function to transfer my setting from my desktop to my laptop. The portable came from the desktop so I can see it possible that the problem originated there.

Installing on a VM on the same machine to test something is fine.

OK well thanks Leo I'll test it today, I'll come back here with the results good or bad.

First I apologize for taking forever responding to this.The laptop I've been working this issue out on went out for repairs and it took them a while getting it back to me.

Back to the issue at hand I have wiped and re installed everything on my computer, I haven't migrated anything to prevent setting contamination trying to avoid the same issue. This appears to work because the issue hasn't resurfaced on this computer. I also tested it on a virtual machine which also didn't repeat the issue.

Thanks for you help Leo

I can confirm that this is happening on my computer as well. If I scroll down in a Lister (file tree side) and then hover the cursor over another file, the Lister jumps back to the top, or, if I had selected a file earlier, it jumps up to that file. I am running Windows 7 Ultimate (32-bit) and I am using a Logitech m705 wireless mouse. I am using the default Windows driver(s). I do not have any Logitech software installed.


I'm not sure where this issue popped up for me, I have 2 machines running Dopus and one portable license that I used off a flash drive that is taken everywhere. I had originally installed Dopus on my desktop and laptop using both systems regularly but doing all my customization to the desktop install. I've so far used an application launch bar where I drag a drop files to open them with the corresponding application. I have 3 bars of various folder shortcuts, finally I changed the color of most of the windows / toolbars to a darker slate color.
I haven't done much coding to the Icons so with everything said I'm not sure where the issue came from. I know it carried over as soon as I copied over the settings. I haven't ever had the issue with the portable version because I had to build that setup differently because it was pointing to different directories.

You seem to be running a very similar setup to mine except I'm running 64bit. I fixed mine "so far" by completely wiping my machine and re-installing it.

I'm hanging onto the one that's messed up in hopes of trying to fugue out what Is causing the issue.
Good luck with yours.

This seems similar to an issue fixed in recent betas. Are you still seeing it in Opus 11 beta 10?