GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Viewer Pane: built-in audio player suddenly not working

Hi everyone!

First of all, thank you SO MUCH for this amazing piece of software. I have been using the trial for 2 days now, and it has already made my life a lot easier. Very much looking forward to purchasing the full version!

That being said, something very strange happened yesterday. I got a prompt from Quicktime Player 7 asking something about associated files... Embarrassed to say I can't remember what it exactly was, as I mistakenly clicked on it without paying too much attention. Anyway, after this the built-in audio player hasn't been working anymore in the Viewer Pane.

So far I've tried out the following, with no success:

  • Re-installing Dopus
  • Re-installing WMP from Control Panel
  • Uninstalling Quicktime Player
  • Viewing files from the Win File Explorer (WMP preview works fine!)
  • Making sure "Use internal player for WAV files" is turned on

I'm able to use WMP as the preview player in Viewer Pane, but only without auto-play - if WMP is disabled from plugins, it will only show the "shell icon" for the file. What happens is that if I disable WAV from plugins, it will show the shell icon, but if enabled, it will show a different kind of icon, with a waveform but not the player itself. If I double-click the file, it will proceed to open the Player, which interestingly works fine in a separate window.

Any help would be greatly appreciated, as I loved having the audio files auto-play from the Viewer Pane - thank you so much in advance!

All the best,
Artur Uronen

Try setting WMP as the program to open the audio file type(s) you're trying to play, using the Windows default programs Settings page.

That usually repairs the registry settings, and you can assign them back to something else afterwards*.

(*Although I would avoid QuickTime as it has a long history of trashing other components and registry settings.)

Hey,

Thank you so much for the quick reply - I really appreciate it! Of course I forgot to add that I also tried this last night... With no success either.

Yes - I didn't even know QT was installed, and removed it quickly. Seems like it already did some damage though.... Aargh!

Hey,

Here's a small update:

I decided to try re-installing QuickTime 7 to see if there'd be anything I could access from the program settings. Didn't find anything unfortunately, but the software gave me the same prompt window, and this time I was wise enough to write down what it said:

"Some of the file types associated with QuickTime applications are currently associated with other applications. Should I restore these file type associations to QuickTime?"

If anybody else has any experience on undoing this, I would REALLY appreciate hearing tips!

It's probably the HKEY_CLASSES_ROOT\MIME\Database\Content Type part of the registry which QuickTime has trashed. That's what it always used to do.

e.g. audio/wav under there should have CLSID = {cd3afa7b-b84f-48f0-9393-7edc34128127} which is one of the identifiers of the Windows Media Player ActiveX control.

Unfortunately, WMP seems to use a slightly different identifier for each extension instead of only one ID (I'm not sure why), so it isn't as simple as setting that same value on every broken type:

(That one has f instead of b before the first -, if you're having trouble spotting the difference.)

If you make a list of the extensions you care about, I can try and export a .reg file that might repair them. (Or look in the same place on the registry on a machine where things still work, if you have one. That will give you the CLSID values.)

Leo,

That WORKED! Thank you so, so, so much. Replaced the registry code with the text you had, and the WAV autoplay work 100% again!

I can't remember whether Dopus autoplayed all of these formats, but if possible, I would love to have at least MP3 as well as:

aif / aiff
aac
flac

Again, thank you so much!

auido/aiff and audio/x-aiff have CLSID {cd3afa72-b84f-48f0-9393-7edc34128127}

audio/aac doesn't have a CLSID here. Adding one of the others might work but I'm not sure.

audio/x-flac has CLSID {cd3afa7f-b84f-48f0-9393-7edc34128127}

If you need audio/mp3 and audio/x-mp3, they're {cd3afa76-b84f-48f0-9393-7edc34128127} and also have AutoplayContentTypeHandler = MusicFilesContentHandler

Let me know if you need any others.

Leo,

This is extremely weird... After typing in those values everything WORKED 100% until after a few minutes they stopped working again. I will try all of the previous steps once again to see if the problem would go away, and report here if I'm still stuck... I had a very happy 2 minutes there though! :laughing:

By the way, thank you so much for your amazing customer support, I really do appreciate it!

2 Likes