Viewer Pane plays audio from a video but not the video

Hi. I'm in the latest release of Opus running on Win10. The Viewer Pane is working fine for all media types except MP4. For MP4's it is playing the audio from the video file but not the video itself.

I've tried switching the default windows app for video to Windows Media Player but that didn't work. I've tried installing the latest version of VLC and that didn't work.

Anything else I can try?


Which video viewer are you using inside the preview panel? It should say at the top, next to the file name (if the pane is wide enough).

Does the same file play properly in Windows Media Player?

The file plays in both VLC (which is the default player for MP4) and in WMP. The header says (the file name) and then (1280 x 720 x 0 Movie)

If you disable the Movie plugin (Preferences / Viewer / Plugins), Opus will fall back on an alternative video player. Does it work then?

Yes - that worked.
Videos are playing.

So, what's happening here then?

Probably a video codec that works with one method of playing videos but not another.

Okay - thanks for the quick turnaround. Much appreciated.
Case closed!


I am having the same issue. When I uncheck movie plugin, I think "ActiveX + Preview + Office + Web" takes over and shows the video. But previusly it was working fine with the movie plugin enabled. The thing I liked was that I could zoom in and out and other stuff which now I cannot with the new player interface.

I have MPC-BE x64, VLC, SM Player installed other than Windows 10's default player. Video files work fine when opened in any ofthe apps but unable to show then in view. I have also tried changing the default app and tried to preview in Opus after every change but didn't work.

I installed 12.25 just this morning, somewhere after a couple of hour or so it stopped showing the viseos in viewer pane. I don't remember doing anything that might change any configuration.

Refine: Only mkv is working, no other video file. Audio working on all video formats

Have you looked at the FAQ on this issue?

Yes I did before posting the issue here. Didn't work

Note the issue is not that the videos are not working, As I mentioned, I can make them work through ActiveX but that has limited functionality. Would like it it work with movie plugin enabled (only audio is working atm, not video) as it gave me lots of options I am not getting from ActiveX

Any word?

That's the only advice we have.

We'll be rewriting the movie plugin in the future so it uses different codecs, since Microsoft seem to have stopped shipping the ones the Movie plugin needs by default. In the mean time, doing things via the ActiveX plugin to use WMP is the easiest thing.

PS: Please link your account.


I am still in evaluation phase so maybe linking might not be possible as I can't see my activation code in Help > Licence Manager > Currunt Certification Status.

I hope I can still post my quries in Help and Support as I might have other queries before finalizing.