Visual Studio - Open Folder in File Explorer not launching DO

Does anyone have any idea why "Open Folder in File Explorer" from within Visual Studio stopped working on folders and projects after installing DO 13? It correctly opens DO if I click a file (in Solution Explorer) and select "Open Folder in File Explorer", but if I right click a folder or a project it instead opens Windows Explorer.

This used to work correctly with DO 12, where both opened in DO.

Any tips on how to solve this would be greatly appreciated.

Currently tested with version DO 13.0.48 Beta on Windows 11 and Visual Studio 2022 17.8.0.

When it opens a folder, VS must be explicitly running Explorer rather than the default folder handler (e.g. ShellExecuteEx on the folder with verb set to null).

I'd expect 12 & 13 to be the same here, as the mechanism for this stuff hasn't changed between the two.

Well, I have two computers running VS 2022 17.8.0 in Windows 11, one has DO 12 installed, and there VS opens DO when I right-click a project and select "Open Folder in File Explorer". This is how it used to work on my other computer before upgrading to DO 13 as well, so something must be different somehow.

I reinstalled 12 and you're right. I'm surprised as it should be the same for both.

We'll look into that. If it worked in 12 there's no reason it can't be made to work again in 13.

Thanks. Glad to hear you could reproduce it, so it wasn't just me going crazy. :slight_smile:

Looking forward to a solution. Love the new beta and its dark theme otherwise! :slight_smile:

Found the cause and have fixed it for the next beta. (If VS is open when you install the beta, the fix will happen next time it's restarted.)

Many thanks for reporting it!


Works like a charm in 13.0.49. Thanks for a quick fix! :slight_smile:

1 Like