Visual Studio + Open Folder in File Explorer

In Visual Studio, when you right click a project, you have an option "Open Folder in File Explorer". The issue is that while I have DO installed, it still opens the folder with the standard Windows file explorer. Does anyone know of how to get it to open using DO instead?

thank you,

From "File Explorer" I assume you're using Windows 8, so I tried on a Windows 8 machine with Opus and Visual Studio 2012, and it opens the folder in Opus here.

Is Explorer Replacement turned on in Opus, and does it work from things other than Visual Studio?

Yes, I'm running Windows 8 and Opus (4779) x64. This happens in Visual Studio 2012 "Open Folder in File Explorer" as well as Visual Studio 2010 "Open Folder in Windows Explorer"

The Explorer Replacement setting is set to "Replace Explorer for all file system folders (recommended)"

If you make a folder on your desktop and double-click it, does it open in Opus?

Yes, double-clicking on a folder on my desktop opens in Opus.
Double-clicking the User's Files folder on the desktop opens in Opus.
Double-clicking anywhere on the desktop opens Opus.

Thanks for checking those things.

I've attached two small programs which will do another test, which is more like what Visual Studio does (they both call the SHOpenFolderAndSelectItems API): (67.1 KB)

If you run TestExplorerReplacement_32bit.exe then you should get an Opus window with C:\Windows\write.exe selected.

If you run TestExplorerReplacement_64bit.exe then you should get an Opus window with C:\Windows\notepad.exe selected.

If they both open Opus then there's something strange going on, but if either one opens File Explorer instead of Opus then it's possible Opus's DLLs aren't registered properly.

[ul][li]If that's the case, try reinstalling Opus over the top of itself. (Don't uninstall first; that would wipe your config and isn't necessary.)

[li]Another thing that's worth a try is to disable Explorer Replacement via Preferences, click OK, then re-open Preferences, re-enable Explorer Replacement, and click OK again. That will re-write some other registry settings which may not be as they should be.[/li][/ul]

ok, I ran both executables as instructed and the behavior is exactly as you described. The 32bit one opened Opus with C:\Windows\write.exe selected and the 64bit one opened Opus with C:\Windows\notepad.exe

So look's like something strange is going on.

I tried disabling Explore Replacement and then enabling it again as you instructed, but it's still behaving the same.

Did you verify the calls to SHOpenFolderAndSelectItems with VS 2012?

What tool did you use to monitor the API calls? maybe I can run that on my machine to see what exactly is going on in mine.

Looking into it, VS2012 uses SHOpenFolderAndSelectItems for files (e.g. right-click a document tab), but does a ShellExecute with the "explore" verb when opening a folder (e.g. right-click a project).

If Opus isn't catching the ShellExecute, maybe its hook isn't installed right. The two suggestions (reinstalling over the top of itself, and toggling Explorer Replacement) should ensure the relevant registry settings are set for that.

ok, I'm not sure how exactly, but it's working now. I think disabling Explore Replacement and then enabling it again fixed it, but I needed to close Visual Studio and start it again as that is the only thing I've done since then. I may have also restarted the OS, but I'm not 100% sure. Anyways seems to be working now, thanks for the help.