VLC Not playing mp3's on launch

Some time ago, launching VLC with an mp3 stopped working. Really frustrating. Works great with mp4, avi, mkv, etc but mp3 just doesn't work. I have to open the file manually from within VLC itself, or if I want to just double click on files and have them open the regular way, I have to use explorer instead of dopus. I never changed the file launcher info in dopus, and I tried changing it, resetting it, etc to no avail. It DOES work to right click on the file and use the context menu "play with vlc." Not sure what's going on, but I would like the double click functionality to work again. Any thoughts?

Try picking VLC from the Open with context menu and making it the default.

Yep, tried that too, no dice. I even reinstalled VLC.

Please do the following:

  • Select Settings > File Types in Opus.
  • In the window that appears, select File > Diagnostic at the top left.
  • Type .mp3 into the extension field and click OK.
  • Repeat for one of the other file extensions which opens in VLC successfully.

You should now have two zip files, one for each extension on your desktop. Please attach them here or via private message. (They don't usually contain anything very private; just application names and paths, unless you've added something unusual to your file type actions. Everything inside the zips is a text file, so you can look inside them to see what kind of data they contain.)

For s&g's I tried double clicking on a wav file and it doesn't play them either. Here are all three diagnostics, the mp4 works properly, mp3 and wav don't.

Opus_FTD_File_mp3.zip (59.7 KB)
Opus_FTD_File_wav.zip (59.8 KB)
Opus_FTD_File_mp4.zip (60.3 KB)


Your Music file type group is set to run VLC.exe without passing it any filename to open when you double-click a music file:

Try changing that to:

"C:\Program Files\VideoLAN\VLC\vlc.exe" --started-from-file --no-playlist-enqueue {filepath$}


  • Paste /dopusdata/FileTypes into the path field in Opus and push return.
  • Delete VLC.mp3.oxr from there.
  • Use File > Exit Directory Opus to completely exit the program.
  • Re-launch Opus and confirm the file is still gone.

See if things work now.

The first part did it, thank you. I'm curious though - it used to work and then all of the sudden it stopped working. I never changed anything... any idea on why that would have happened? Also, do groups override individual file types? I would have thought the "open" settings on .mp3 would have worked just fine.

I'm not sure how it could ever have worked with that there.