Where to find this preference?

A while ago I setup file/folder formats. Such as changing the color of a file if it is less than 5 minutes old so I can find the new files easier. Or to change the color of folders if they start with a "!". It has been so long since I set those formats that I cannot remember where to go look anymore.

I have been playing with my config file and one computer the folders starting with ! are green as I want them, but on another they are not. So I messed something up, a while ago, but cannot recall where to go look anymore.

I finally found it...

But this format is not working. On the machine that is working, i checked and it is listed the same way. So i copied the config from the updated comptuer and it stopped working. So i put my old config back in and its working again.

I have no idea why this label is no longer working. It should be changing the color for any folder that begins with a ! but it is not.


I tried ticking off the box "use regular expression" but all that did was highlight all folders in green.

I tried to create a new label and put test* and set it to files and folders. i had a file in the folder already that started off with test and it did nothing.

I tried to create other wildcard filters for something else as a test. test* for file using the regular expression box and then that worked.... but wont work for folders.... not sure what else is interfering. As it works on an older config on my other computer. I was just updating my config on one computer to the way I wanted it then would just install it on the others. Not sure what I did to break this

If I change the wildcard to be * !* instead it works, but then all the subfolders whether or not the have a ! in it also have the formatting. But by putting the * in front then any folder that has a ! anywhere in the name is highlighted. So not really what I want either.


Try using *\!* as the wildcard. I think it's testing against the full path.

These days, there is an option to only match the name, not the full path, but it looks like you're on an older version.

I tried this.... but the problem is...The parent folder that has a ! in the beginning is green, but then so are all the subfolders, including the ones that have no ! in it.

So if I have a folder c:!test .. then that folder and every single folder inside of that is also green. I just want folders starting with ! in the current view to be green. If I go to a subfolder, then everything should be default unless there is another folder starting with !

My other computer has a new version of v12 than the computer I am on now... and it does not work there. I am running v12.12 on this computer and 12.33 on the other one. On the v12.33 machine the wildcard !* works when using the older config file. The minute I install the newly modified config file, which also has !* as the wildcard, it stops working. So there is something in my config that is messed up. Just not sure what

January was when I setup the other computer with my config from this computer. And it works with that config. Same settings !* and it works... And it had worked on this computer as well back then.

This older system v12.12 I have been making a lot of changes, mostly to icons. and some filepaths I want to open by default. Stuff like that. So now I have it the way I want, I wanted to send the config to the other computer so it is up to date as well.. That is when I noticed that this particular setting stopped working. I have other labels set up, but this is the only one that is in the wildcard setting.

What is weird is that I tried the old config from my other computer that does work properly. Imported to this computer... the !* does not work on this computer. I even tried an older config from 2023 and nothing.

Opus 12.33 includes the "match full path" option, so just update the really old version on one of the PCs and use that (i.e. turn it off so only the name is matched) with the simple !* wildcard.

I will update later... but what i did for now...

  • update the config on the 12.33 with the new updated version.
  • remove the match full path as it was enabled

works now.

So i will upgrade this computer.... but what is interesting is i could have sworn that it had worked on 12.29 before. Maybe it did not. My mind is not what it used to be :stuck_out_tongue:

Hard to say without knowing exactly what you did.

I haven't checked if the checkbox was also in 12.29; that's the first mention of that version in this thread. You said one machine was on 12.12 (years old now, and I assumed the version shown in your screenshot above where the checkbox is missing) and the other 12.33 (the latest release of Opus 12, which I've checked includes the checkbox).