Why does this DopusRT command work in Terminal but not in CMD?

Dopusrt.exe /acmd Go "c:/"

The above command works, last active Lister goes to c:/ but the below command does not work.

Dopusrt.exe /info documents\filelist1.txt,listsel,0

The weird thing is it works just fine in Windows Terminal. Does CMD reserve commas for something? I really need to use CMD in this case, Since Auotohotkey seems to only speak to CMD.

Thank you.

You'd normally need the full path to dopusrt.exe, since it's not in the default path.

You may also need to give a full path for the output file. Relying on the "documents" folder being under the current dir may not work if AHK is running things with a different current dir.

1 Like

Hey Leo, thanks for the prompt reply, I really appreciate it!

I was trying all sorts things such as;

Run, %comspec% /k cd "C:\Program Files\GPSoftware\Directory Opus\" && %ComSpec% /k "dopusrt.exe /info documents\filelist1.txt,listsel,0"",, Hide
Run, %comspec% /k cd "C:\Program Files\GPSoftware\Directory Opus\" && % ComSpec "/k dopusrt.exe /info documents\filelist1.txt,listsel,0",, Hide

I took AHK out of the equation and it still was not working in just plain cmd, I would set it to the needed directory but nothing would happen.

You may also need to give a full path for the output file.

This is where I was going wrong! it works now!

That probably would've tried to output it to a documents folder under your Opus folder, which presumably doesn't exist (and would normally require admin rights).