GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Win10: setting DO's viewer as the default image viewer


#1

Sorry if this has been answered before -- I searched and could not find.

Within Opus I have the internal viewer registered as the default image viewer.
But on Windows 10 I cannot figure out how to register it system-wide: the "set default app" menu does not have a Browse button! The only option seems to be to select from the store. What? I have to go to the store and cannot select from my drive? It's been a long time since Windows upset me so much.

I see that I can register d8viewer on a file-type by file-type basis and have done so for jpg, gif, png.
But is there a way to set it as the default image viewer, regardless of extension?

Thanks in advance for any tips.



#2

Instead of using the control panel, find a file of the appropriate type, then right-click > Open With > Choose Default Program.

The UI that appears is similar, but has more options, including the ability to browse for an exe.

(Scroll to the bottom, if what you want is not not already in the list, and choose More Apps. Then scroll to the bottom again, if it's still not in the list, and choose Look for another app on this PC. Then you get a file browser. At least, that is how it works in Windows 10 on 14 Dec 2016. MS keep changing this UI so it may be different tomorrow. :slight_smile: After choosing the program for one file type, it should then be in the list for others, and for me at least it appears in the control panel as well.)


#3

Leo I've wondered on this too. If browsing what do we point the system at, the main DO exe?


#4

No, use d8viewer.exe instead.


#5

Thanks Leo!


#6

That wasn't Leo :slight_smile:


#7

Leo's answer would have been more informative than mine :slight_smile:


#8

Sorry guys, only quickly logged on from work to reply and as it is usually Leo that gets there first I assumed...... :slight_smile:


#9

@Leo
from my original post:

So what you suggest is something I'd already done.
My problem is how to set it as the default image viewer, regardless of extension. d8viewer is just not showing globally when accessing 'set default programs' for pictures.

I'm sure there's a registry entry somewhere.


#10

It's set as the default image viewer here (whatever that actually does/means; what happens if a new image format comes out that the chosen viewer can't handle?) but I don't know what I did to make that happen.

As far as I know, I just set it as the default for the various image types I wanted, but maybe I am forgetting something.

It's also possible I did something which the Windows UI no longer allows.


#11

It's mind-boggling that W10 offers to browse the app store but not your hard drive to set a default app...

When are you guys coming out with Opus OS? I'm ready to switch over. :slight_smile:


#12

Thank you was also looking for this.


#13

Whether to use the DO viewer system wide, would make a good question at installation time of DO, right where it asks whether to replace explorer, handle zips etc.?! A quick button somewhere in the prefs to set the viewer as default would also be nice. I always struggle to remember how to set this up correctly. o)


#14

Then we'd have endless complaints from people who just clicked through without reading the question, demanding to know where their preferred viewer had disappeared to :slight_smile:


#15

Solution: Offer this as an "opt in" option! o)


#16

Struggling with this again after a Win10 update. You can still right-click on a jpg, choose 'open with d8viewer', but if you choose 'always open with d8viewer', you run into problems. Seems like Windows tries to update the 'Pictures' group, sees that d8viewer is not a registered app, and leaves the default Pictures app unset. So next time you click on a jpg, you get 'Windows does not have a viewer for this file type'. If you go into file associations in Windows and try to set Pictures to open with d8viewer, just like before d8viewer does not show up in the list and your only option is to choose an existing program or visit the store.

Seems like all would be solved if we could 'register' d8viewer so it shows up in the Pictures file association list. Any idea what this would take?

Any other suggestions welcome. I'm trying to view images from Newsbin Pro, which just fires up the default Windows viewer. Photo app doesn't have a viewer, it opens in edit mode. Also have AcdSee, but the viewer leaves a lot to be desired... d8viewer is definitely my favorite.

Thanks!


#17

Any idea which Windows update it was?

My system still opens things in d8viewer.exe fine and has no updates pending. (I still haven't received the 1809 update, if that's the one.)

Try using the option to choose other apps and select d8viewer.exe by path, in case the registry settings for the d8viewer.exe you have are incorrect.

If you updated Opus recently, make sure you've rebooted since the update.


#18

I'm running 1803 at the moment.

In File Explorer, if I right-click on a .jpg and choose 'open with', then choose 'choose another app', then 'find an app on this pc', navigate to d8viewer.exe, click on 'always use this app': it shows the file in d8viewer just once. If I double-click on any .jpg after that, it goes back to opening the .jpg in whatever program is selected as the default handler for Photos. Settings will not let you choose d8viewer as the default for Photos.

Have tried this several times with no success. Think I'm doing everything right - this surely isn't new to me.

I'm not sure exactly which Windows update caused this. I did just update Dopus to the current release and have rebooted since. I've been suffering with the AcdSee viewer for a while and finally had ten free minutes to get d8viewer going again and of course noticed the problem then...

Can you try changing your setting to Photos and see if it will let you switch back?


#19

Changing the default to the Photos app reproduced the same issue on my machine.

From searching the web, this is a widespread bug in Windows 10. The Open With > Set Default option is simply broken right now. The quality control on Windows 10 is completely in the toilet these days. It's ridiculous.

This worked for me:

Open an administrator command prompt, then run:

assoc .png

That should report pngfile as the file type class, usually.

Assuming that's the case, then run:

ftype pngfile

It'll report the current association. (Not that important, but may be worth knowing before we change it.)

Then run:

ftype pngfile="C:\Program Files\GPSoftware\Directory Opus\d8viewer.exe" %1

If you get an access denied error, make sure you're using an admin command prompt and try agan.

Running ftype pngfile again should reflect the change.

Now, you'd think that would be enough to make things work, but it isn't. You'll still get the other program when you double-click. BUT, if you now use Open With to set the default to d8viewer.exe, it will work.

Windows 10 is shoddy piece of work. I'm starting to dislike it as much as Windows 8, albeit for very different reasons. Sigh.


Open chrome images default picture viewer
HOW TO: Use the Opus image viewer inside or outside of Opus
#20

That did the trick. Brute force required again! I didn't stumble across any bug reports on this in the first few pages of results, but I suppose I should have looked further.

Win10 is great compared to Win8. Before I retired in January, I was managing security client roll-outs to literally tens of thousands of users across multiple fortune-100 corporations. The couple years of Win8 cost me most of my sanity. Win10 was far better... and better than the Mac before those guys chime in... But there is LOTS of room for improvement!