Win11 Images and Photos App

When I try to open a file associated with the generic Windows 11 Photos app I get 2 error messages.

The first:
The specified procedure could not be found.

The second:
This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default App Settings page.

The messages appear (in that order) when double-clicking any jpg, png, etc.

I have tried Open with > Photos
When I do that, I only get the first message.

If I try Open with > Choose default program... > Then leave the default (Photos selected), and hit OK.
It opens fine.

This does not happen in Windows Explorer.

I have tried associating JPG with MSPaint and that seems to work fine. I then set the default back to Photos and the issue returned.

Any ideas or workarounds?

Which version of Opus are you using?

I don't have any issues with Opus 12.26.1 and Windows 11's photos viewer (latest Windows updates installed).

Have you changed the filetype double-click actions within Opus at all?

You shouldn't need to, but you can probably work around the issue by doing this:

  • Settings > File Types.
  • Double-click the Images file type group (or individual image types if you only want it for specific types).
  • On the Events tab, set Left Double-Click to run this:
    FileType ACTION=shellex

Version info:
Directory Opus Pro 12.26.1 (Beta) Build 8055 x64
OS 10.0 (B:22000 P:2 T:1) SP 0.0

I have not changed the double click actions (to my knowledge).
Tried your fix. Same result.

Is there a quick way to reset to default config? I could backup my settings and try the default config to rule something I did out.

Quickest way is to uninstall Opus, reboot, then install it again.

Make sure your config backup is up to date first, and stored somewhere safe, since uninstalling will wipe the config.

I just started having the same issue with .jpg files; just started my 2nd week in to Windows 11. And, didn't change anything at all. Is there any more recent solution other than uninstall / re-install Opus?

Uninstalling/reinstalling Opus probably won't help. That was just in answer to the question of how to quickly reset all Opus settings to their defaults at once.

The issue is likely in your registry, or in something interfering with one program launching the other (e.g. antivirus), and not in your Opus configuration.

Right-clicking one of the files and using Open With > Set Default usually fixes issues with registry settings.

Edit: Another thing to try is my suggested Left Double-Click event, above.

If that command doesn't work, you could try this one instead, which explicitly launches the Windows Photos app via its system app identifier (the random looking text starting with "AppX..."):

FileType ACTION=shellex SHELLCLASS=AppX43hnxtbyyps62jhe9sqpdzxn1790zetc

FWIW, I still don't see any issues on my test Windows 11 machine which is up to date, and haven't had to do any of this, or anything else special, to be able to launch the Photos app from Opus.


Thank you. What worked is opening windows explorer, right-clicking the .jpg and choosing open with and then selecting Photos and the default checkbox. Once photos opened, I closed it.
Closed Directory Opus completely.
Opened Directory Opus, problem solved.

Note mine is a Windows 10 to 11 upgrade, which while it went smoothly, gremlins abound.


1 Like