GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Windows 10 1903 and Opus Startup

I like to start my Opus sessions with a particular tab group open, with thumbs set at a specific size and the Opus window at a certain size and position
To that end I made a user script about 18 months ago:

Go TABGROUPLOAD=Tome
Set LISTERSIZE = 2800,1840
Set LISTERPOS = 100,10
Show THUMBNAILSIZE 320

I stored it in the user scripts and have used it successfully ever since - or at least until Windows 10 1903 and/or one of its updates came along.

Now the script does not work at startup, even though my config, of course, is still instructing Opus to use it.

Instead the USB drive I use to store my file backups appears in the root directory. This may be significant as this drive fell foul of the Microsoft bug that can lose the identity of attached USB drives when the 1903 update takes place.

That problem is easily fixed, of course, in Disk Management, but the Opus startup is proving more problematical.

Not the worst problem in the world, but annoying nevertheless. I am using Opus 12.14, by the way.

How are you running the commands exactly?

How are you launching Opus?

If you turn off Explorer Replacement in Opus and reboot, does the USB drive then open in an Explorer window instead?

I know there is nothing wrong with the script as I use it to launch Opus from the desktop and it works every time.

However, going through your suggestions seems to have produced a fix. I turned off Explorer replacement, tested I could see the drive as you suggested in explorer (I could).

And interestingly, with Explorer replacement off, the script starting working at startup.

I turned Explorer Replacement back on and it still works.

I do not know what you did, but thanks very much.

I suspect rebooting is what really fixed things.

Something was probably causing the USB stick to be opened during startup, but no longer is now fir whatever reason.

I spoke too soon. The problem has not gone away.

However, I can fix it by turning on Don't Replace Explorer in Preference/Launching Opus/Explorer Replacement

Opus now launches the script at Startup. If I turn this setting off, it does not.

BTW the script runs fine when I start an Opus session by double clicking on the desktop.

It does not work if I use the Win + E key, which matters not a jot to me.

I suspect something on your system is opening a folder at boot.

Does an Explorer window open if Explorer Replacement is turned off and you reboot?

No, it does not. I will start having a look through my startup items to see if I can track it down.