GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Windows 10 This PC, Manage not working

This may not be related to Directory Opus replacing the Windows File Manager. Has anyone else had difficulty making "Manage" work under "This PC" (on the desktop)? When I right click on "This PC", and select "Manage", nothing happens. I can create a shortcut to Computer Management on the desktop or get there several other ways (that work), but it would be useful to fix the right click option under "This PC" which now invokes Directory Opus. I'm running Opus 12.21 x64 under Windows 10 x64. Running SFC /scannow and DISM doesn't fix it.

The "Manage" option opens Computer Management for me. I don't have the Windows 10 2004 update yet, so if you have that then it could be the difference.

What happens if you turn off Explorer Replacement (Preferences / Launching Opus / Explorer Replacement: Don't replace Explorer)?

Thank you for the quick reply. I turned off Explorer Replacement, and still cannot launch manage. It starts an hourglass, but nothing opens. I tried launching "manage" from within the Windows File Manager as well, and had the same issue (hourglass but no management window). Thank you for helping me pin this down (it isn't Opus). I'm running Windows 10 1909.

Maybe a workaround, but from the Superuser.com site, I found this solution:

  • Open regedit
  • Go to "Computer\HKEY_CLASSES_ROOT\CLSID{20D04FE0-3AEA-1069-A2D8-
    08002B30309D}\shell\Manage\command"
  • Right click on "command" key->Permissions->Advanced (I changed the {20D04...key} instead)
  • Change Owner to your user (I used Administrator...yea, I know the danger)
  • Add your user to "Permission entries" with "Full Control" permissions (I changed Administrators from
    "Read" to "Full Control" Access, and clicked the option to Replace all child object permission entries)
  • Press Apply and OK to close the Permissions Window
  • In "command" key modify the "(Default)" string from:
    %SystemRoot%\system32\CompMgmtLauncher.exe
    to:
    mmc.exe %SystemRoot%\system32\compmgmt.msc
  • Close regedit

I took it a bit further by restoring the Administrator's permission to read, and clicked the option to Replace all child object permission entries, clicked Apply and OK. Then I closed regedit.

Now right clicking on the desktop "This PC" and Manage works. I don't know what the issue with the
CompMgmtLauncher.exe is, but this works.

I think you need to do something like running sfc (System File Checker).

Thank you for the suggestion DesertDwarf. I when I ran SFC and DISM, they didn't correct the problem. I agree that they should, but didn't fix my problem. In searching the web, I found several other reports of a similar issue with manage not invoking the computer rmanager. The solution I posted above worked for me.