Windows 11 12.26 OneDrive context menu problem

Hi there. I have installed the latest version (12.26) but I still cannot see the OneDrive context menu.

I also reset all DOpus settings but still no luck. Am I doing something wrong (see picture)?


Does the Availability column work in the OneDrive folder?

Hello Leo, yes Availability is there:

If you move a file to the cloud ("Free Up Space" in the context menu, via File Explorer if it's not in the Opus menus), does the Availability column indicate the change, or does it still say "available on this device"?

Another thing to check: If you type /onedrive into the path field and push return, does it take you to that folder, or somewhere else?

/onedrive correctly takes me to the folder.

Also, freeing up space does reflect in DOpus (see picture) however the option in Windows Explorer wasn't there initially because I have Files On-Demand disabled (I like to keep my files available all the time). Maybe this is the issue?


Thanks for testing those! That rules a few things out.

It could be involved. Would it be possible to try turning it on to see if the menus appear in Opus then?

(Jon knows more about this than I do, so he may have more ideas when his timezone wakes up.)

I have tested as requested but unfortunately, the menus still don't appear:

Is that not them there? Although they are still disabled for some reason:

Hi Leo. Sorry my misunderstanding but shouldn't there be links to:
Share, View online, Version history (see picture from Windows Explorer)?

I regularly need to view the document online or look at previous document version history and can now only achieve this by opening Windows Explorer.


What version of OneDrive is that?

Version 2021 (build 21.220.1024.0005). It should be the version that is standard to Windows 11 as I haven't installed a new version.

Is OneDrive for Business/School/etc. also installed? (Usually as part of MS Office.) I think the blurred out name after OneDrive is usually there when it's that version, to show the account or organisation name it's tied to. But it's possible the Windows OneDrive also shows it sometimes and I just haven't noticed.

Hi Leo, I use OneDrive and also OneDrive for Business - however, both version numbers are the same (they are different colour on the task bar though).


Hello Leo.

I can confirm the behaviour is the same in standard OneDrive as well (see picture).

Any updates on this - it would be great to see this in Opus (otherwise if I want to see version history, I have to open the Explorer).

That shows File Explorer, but which menu items do you see in Opus?

Have you tried holding Shift while opening the menu?

Hi there. Still no OneDrive integration with Directory Opus (so have to open Windows Explorer a few times a day which is frustrating). I have done a full reset but still no luck. I don't understand as other members have got it working with 12.26???

Hope you can help.

Here are pictures of the right click menu without and with Shift:

I just noticed in these screenshots that the status column isn't visible - did you turn it off? If not, it might mean that Opus just hasn't detected this as a cloud folder.

If you add the folder's path to Preferences / Miscellaneous / Advanced [Filesystem]: cloud_sync_paths does it make a difference?

Whereas before I didn't even see the context menu items in 12.25, but then they showed up in 12.26, the only issue I am now facing is that the "Free up space" context menu item is only active for files and not for folders. That is, in Explorer, I can select one or more OneDrive folders, right-click, then select "Free up space."

Seldom do I free up space on a file-by-file basis; it's usually at the end of the work week on multiple work-related folders.

That worked - thank you so much.

It must be because I do not use the default location for OneDrive. Once I manually added the location, the options appeared.