Windows 7 - saving Hotkeys

sorry for new topic - can' find needed...
i can't save hotkeys at all! alt+c (copy path), ctrl+z (copy filename path instead undo), shift+ctrl+c (copy filename)... what's this?

and ctrl+v doesn't works in command editor!!?? but paste in other places

What are you trying to do and where?

i open customize-keys and try to make new key.
function: Clipboard COPYNAMES
hotkey: alt+c
click on 'ok' but the result doesn't save!
and so on... ctrl+z, shift+alt+с ... i can't save anything

Sounds like there is something wrong with the permissions or read-only flags in your Opus config folder that is preventing Opus from updating /dopusdata\ConfigFiles\hotkeys.oxc

all files in "...AppData\Roaming\GPSoftware\Directory Opus\ConfigFiles" changes normaly and i have admin rights, but hotkeys.oxc doesn't updates...

hotkeys.oxc source looks like this:

copy filename
copy filename to clip

Clipboard COPYNAMES=nopaths

problem in 255,5!!??

copy filename copy filename to clip Clipboard COPYNAMES=nopaths

i change "255,5" to "alt+c" but nothing changes

why i can't paste full code in message body?

hotkeys-file body

Which keyboard language/locale is your machine set to?

BTW, if you use the Quick Reply form then it breaks XML posted to the forum. Click Post Reply instead and (so long as the "HTML" option is turned off) XML will paste okay.

:slight_smile: english & use quick reply

Try editing the file to use alt+C with a capital C, and restart Opus. Does that work?

Can't think why it's not working via the customize window, though.

capital C doesn't works! it looks strange, when i delete "...\AppData\Roaming\GPSoftware\Directory Opus\ConfigFiles\hotkeys.oxc", but my Keys still looks like this picture

Can you check the exact keyboard layout language (see screenshot below)? The only time I can remember where something like this happened was because Opus got confused with certain keymaps, though that bug was fixed.

This is an answer!!! :slight_smile: when i set the default input language to english - everything goes right!!! but when it sets to "russian" - red item in key list appears!

thank you, Leo, for your help! what program you use to make your screenshots (on previous post) :slight_smile:))

I use WindowClippings to make screenshots.

You could report the keyboard issue to GPSoft but since there have been zero* sales to Russia I'm not sure it'll get a high priority. (* Edit: Apparently that's not true!)

zero sales?
i'm the FiRST :slight_smile:))))))))) thanx

Hi idiots - developers!

I have to ask me back my money for the program.