Windows x64 Viewer Pane Not Working

I've got a problem with my viewer pane not loading up movie files(except .mpg's but even then I only get sound). I'm almost certain it's windows x64 problem cause viewer has worked straight out of the box back when I was on xp media center. I found faq (i had some problems loading .wmv files awhile back) here but my all solutions there did not work.

I noticed that when i do click on movie file that it opens it .txt format and .txt plugin loads. I disabled it and all i get blank screen(though it looks like it's about to load up for like a half of second).

Just for fyi the codecs i have installed are divx(for divx),coreavc(.mkv's) and ffdshow(for everything else). I don't beleive it to be a codec(only had ffdshow when I first started) conflict though.

Hope this helps, thx in advance

Do you have 64 bit versions of the codecs? The 64 bit Opus can only show movies that you have 64 bit codecs for - 32 bit codecs can't be used. Note that Windows Media Player is a 32 bit app so whether it can play a particular video or not is irrelevant.

Wow i didn't know that, i think there is 64 bit version of ffdshow but it doesn't work to well. I'll try that.

any1 else use 64 bit opus and viewer pane, I'd be interested what codecs you use.

There is a 64-bit version of WMP 11: ... b5067ee958

But my WMP11 is sitting in Program Files (x86) so I must have the 32-bit version which makes me think there must have been a problem with the 64-bit version when I tried it a few months ago.

Thx Jon I unistalled all 32-bit codecs and 64 bit k lite codec pack and worked like a charm, well almost did.

See i was just about to say it didn't work, but just to test it out I went and try it on my admin account(I normally use limited user for everything except upgrading or installing something.) and worked great.

I guess now i think the problem as far as limited user account goes is that it doesn't have full control permission to something it needs. But I gave full control to install in prgram files and even dopus itself.

Any suggestions?

I'm on XP x64 and I've now got some video formats displaying in the preview pane.

First I installed the 64-bit edition of Windows Media Player linked to in my previous post. After that DV-AVI, WMV and MPEG1 were displaying correctly in the preview pane.

I then installed K-Lite Codec Pack 64-bit 1.3.1 from ... 94057842/5

I took the full install but during the installation I set it to decode no audio formats, but ticked every video box except VC-1 (which I don't have any of but which I suspect is already supported by WMP 64-bit).

After that MPEG2 displays correctly and in particular .m2t HDV files which are important to me.

However I still can't get Xvid, Divx, FLV, MP4 or MOV to display in the preview pane and would love to hear if anyone can get those working.

By the way everything I do on this machine is under the "administrator" account.

Just noticed that Windows Media Player is still sitting in Program Files (x86) so I'm guessing it must just be a 32-bit app with a couple of 64-bit decoders (such as MPEG1, DV-AVI and WMV).

You should have two Windows Media Players, a 64-bit one and a a 32-bit one. At least that is how I understand it. I haven't used x64 much in person.

Internet Explorer does that. i.e. 2 versions. But I still only have one WMP11. No mention of x64 in the "About" window though. But I did get it from that link above.

Doesn't sound like it installed right. This page details switching between the versions and mentions:

This page says it's a pure 64-bit process, and one of the comments says it's in Program Files.

I think you are right, it hadn't installed properly.

So I tried reinstalling over the top of my existing WMP installation and all appeared smooth but no change to the program and still in (386) folder.

So then I rolled back WMP (cannot uninstall it) to WMP10 and tried the WMP 11 x64 installer again. This time the installer failed (gracefully) and said it couldn't complete.

So I then tried to update to WMP 32-bit and that failed too, telling me I should go and get the 64-bit version! :unamused:

So then I rolled back my system to how it was this morning before I started.