Wrong Creation and Modification Date Shown

Windows Explorer shows the correct creation and modification dates while Opus appears to be using the accessed date for these two columns.

The dates come from the filesystem, so whatever is happening is quite strange as it appears to be returning one value sometimes and another at other times.

Is the server a Windows machine, or some other kind of NAS? If it's not a Windows machine, my bet is it isn't always returning the timestamps properly for some APIs vs others.

The server is a Windows 2019.

You say the dates are coming from the file system, but why does File Explorer show the correct dates?

I don't know why it would show different dates. It may ask via a different API, or there may be something else involved (e.g. antivirus).

But I do know that Opus gets the dates from filesystem and displays them. If the wrong date is being displayed then the wrong date is coming out of the filesystem (or related APIs).

Have you checked with any other software to see what it displays?

Well, I should have tried something a bit more obvious first, like closing the list and re-opening it. That worked.

Thanks for your help.