GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Zip file default in win 10

I am unable to get opus to be the default app for .zip files in win 10-64 bit.
I have tried by going to Settings/ preferences ...Hitting apply after checking the box makes no difference.
When I try to set the defaults in windows it will not list opus or says it is an unknown
What should I do??

thanks

Please run my FileTypeDiag tool on .zip and then zip up and attach the results.

zip.txt (218 KB)

If you right-click a .zip file and choose Open With > Choose Default Program, does the list that opens include Directory Opus Helper Application? If so, selecting that and the "always use..." option at the bottom should fix things.


I'm not sure that my problem is the same, but it seems to be related. When I double click on an eComic file (which is a zip or rar archive of images, but the extension is rename to .cbz for zipped files, .cbr for Rar files and .cb7 for 7-zip files), DOpus shows me a listing of the contained images instead of launching the Windows default program, which is ComicRack. I have tried resetting the default program through Windows, but that didn't change anything.

I spend a lot of time working with eComic files (I have about 75,000 such comics), and really wish I could get this to work properly. As it is, I have to right click and select 'Open eComic file with ComicRack' to get it to work. Needless to say, that is a less-than-optimal solution for this problem.

Thanks in advance for any help I can get with this issue!

Slightly different.

If you don't care about thumbnails for the comic book archives, turn off support for them entirely under Preferences / Zip & Other Archives / Archive and VFS Plugins.

If you want to keep the thumbnails, but change what happens on double-click, go to Settings > File Types and find the types for them in the main/bottom part of the list. Set the left-double-click event to run the program you want it to run, using {filepath} to pass it the path to the archive.

OK, so first, I was going to try to keep the thumbnails, but your instructions didn't seem to match what I saw when I tried to follow them. I'm not sure where I was supposed to see any 'events'. And I have no idea what you meant by 'using {filepath}'. In the future, when you give instructions to the unwashed masses, it might be best to give step by step instructions to accomplish the goal.

So, I decided to try the first suggestion and just give up the thumbnails. I followed your instructions and went to 'Settings > FileTypes'. There, I saw checkboxes specifically for eComics. I toggled the values there and voila! Now eComics launch the program that was set in normal Windows, ComicRack.

I may no longer have the thumbnails, but I can launch my eComics from a double click directory listing again.

Thank you so much for your help!
Steve

[quote="leo"]If you right-click a .zip file and choose Open With > Choose Default Program, does the list that opens include Directory Opus Helper Application? If so, selecting that and the "always use..." option at the bottom should fix things.

200dpi_wc7840_OpenWith.png[/quote]
Hi Leo,
When go to settings in windows 10, Directory Opus Helper Application does not appear in my list of applications.
What do I do?
Thanks

If you're comfortable using RegEdit, try deleting:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FileExts.zip\UserChoice

If you get an access denied error, you'll need to right-click UserChoice, then choose Permissions, and then delete the Deny permission that may be added against your user name. It should be possible to delete it then.

The rest of this post is just an observation, and not anything you need to do, unless you see other unexpected behavior on the machine.

FWIW, there appears to be something unusual going on with your registry, where the merged HKEY_CLASSES_ROOT (HKCR) view is different to the underlying HKEY_CURRENT_USER (HKCU) and HKEY_LOCAL_MACHINE (HKLM) views:

64 HKCR.zip: "" is REG_SZ: "OpusZip"

vs

64 HKCU\Software\Classes.zip\ -- Does not exist
64 HKLM\Software\Classes.zip: "" is REG_SZ: "7-Zip.zip"

I'm not sure how that combination is possible, since the top line should be coming from one of the other two lines (with HKCU overriding HKLM if both exist), yet it is showing something that is in neither of them. One or two other people have reported similar in the last couple of years, and I think ended up creating a new account/profile on their machines to solve it, although I would not go to those lengths unless I saw other problems with filetypes and/or the registry (which they did).

While I can't explain what the registry is showing there (unless some kind of 'cleaner' tool has been modifying the registry hives directly, perhaps), whatever is causing that unexpected behavior may also be what is preventing the usual ways of changing the .Zip association from working.

Hi Leo, I tried this suggestion and clicking comics.cbz now launches CDisplayEx but it does not open the comic. Just an empty CDisplayEx. Here's my settings - anything I should change?

FWIW, that's the Open Action, not the Left Double-Click Event. But if it's launching the right program then the distinction may not matter.

The command line looks like it would work with most programs, but maybe the one you're running needs different arguments to tell it which file to open. You'd need to look at the instructions for the particular program, or ask its author how to run it if they haven't documented that detail. (Or find out what it needs by finding what it adds to the registry itself.)

and this

Ah! Fixed!

image