11.13 & 11.12 export path-filename bug or feature

Greetings from a ~35-year fan.

Initially found in v11.12 and I saw that 11.13 was out so I tested that too.

When exporting a folder/file listing to csv, and I attempt to manually adjust the export path and filename to:

C:\Users\FLast\Downloads\v2\v2.csv where C:\Users\FLast\Downloads\v2\ already exists by manually adding \v2\v2.csv to the already existing C:\Users\FLast\Downloads\ export path, it appears to accept the path and filename but when checked, apparently it's exporting to a csv named .csv.csv at C:\Users\FLast\Downloads\.csv.csv.

Then after closing and re-opening the export dialog the csv export file path/filename now has C:\Users\FLast\Downloads\.csv.csv.

Thank you for this legendary program and support!

Reference three screenshots included.

Thank you!

Thanks for the report!

I think we have reproduced this. Does this only happen for you if you push return in the File edit box after typing into it? (And not if you e.g. click OK or click anything else in the dialog before pushing return.) If so, we should have a fix in the next version. If not, please let us know and we'll investigate further in case the bug was more complex than it first looked.

Hi Leo!

Thanks for your response.

I rarely if ever push return in file edit boxes and I didn't in this case. I may have tabbed to the next field after typing the "\v2\v2.csv". I have also tried leaving the .csv off. Then I click on OK.

WOAH. I just found another possibly related bug. Standby for screenshots and description. Very rare I'm sure but interesting. I was able to get it to do this other related thing twice in a predictable manner.

FYI, this is actually on Windows 7 x64.

First things first. Now I can't reproduce the first bug. Yesterday I could reproduce it all I want.

What's changed since yesterday:

A. I currently have a v2.xlsx file in the v2 folder whereas I didn't originally. I was trying different combinations such as not pressing anything on the keyboard (not even tab) after adding "\v2\v2.csv" to the end of the export path, and then I clicked on OK. For the record, I am very sure that would be my normal practice. I don't normally do any of what would be considered useless or redundant key presses since I am very experienced in what is and what isn't necessary. I would normally only click on "OK" with the mouse.

B. I just now renamed my v2.xlsx file to "WAS named v2, renamed to try to reproduce .csv.csv bug.xlsx" and still couldn't reproduce the first bug, so I don't know if that filename affected the behavior or not. I tend to think not but I wanted to list it as an item that changed anyway just in case.

C. I rebooted the PC for other reasons.

D. I had also explicitly tried a single tab out of the export path field before clicking OK with the mouse in order to see what that produced, in case it was this action that progressed the behavior to the bug #2 below.

Bug #2:

At this point, I can have this as my export path/file name:


and strangely, DOpus is recreating the file:


You read that right, now it's not even exporting to the correct folder and always exporting to the filename "v2.csv" no matter that I specified "blah.csv".

I had kept deleting the ".csv.csv" file and when this morning trying to duplicate the original (yesterday's) bug, it created the "\v2\v2.csv", I kept deleting it before I tried again, and this is when I started noticing that no matter if I tried to create the file in the Downloads\ or Downloads\v2\ path. Screenshots attached.

I can do this over and over again without ever exiting (Cancel) the file export dialog, if that has any bearing, too.

Ideas that come to me of things to try next, but I'm hesitant to do much at all before getting ideas from you:

  1. Clicking Cancel on the export dialog and reopening it to see if I can still reproduce first bug #2, and then bug # 1.

  2. Closing DOpus and reopening it and then try to reproduce the bugs.

  3. Rebooting the PC again.

  4. Creating a fresh user account on the same PC with a fresh default DOpus configuration in order to try to reproduce the bugs.

  5. Exporting a fresh portable copy of DOpus 64-bit to my thumbdrive with the default configuration and trying to reproduce the bugs on a different PC.

Thoughts on how I should proceed, in order to help diagnose this and determine if it's the program or something specific in my configuration?

Thanks for your time,

The bug was that if the dialog was accepted without the edit control losing focus, it would use whatever path was in the dialog before you manually edited the path. (Using the Browse button was fine.)

It might also happen if another window is clicked on right after typing into the edit control, before clicking OK.

That probably explains both things which are/were happening.

Oh thank you! That is very logical and thankfully does explain both. That's a relief!