13.0.48 start slower after boot

The newest beta start for some reason slower than the earlier ones.
How it behaves:

  • Reboot
  • Doubleclick on desktop.
  • Window with a double lister opens promptly.
  • Both listers are black (have no tekst or info)
  • After a second or two it populates and everything works fast after this.
  • When closing the lister and doubleclicking on the desktop again results in a lister that populates as fast as expected without delay.

It doesnt get slow before I have had a reboot again. And I have tried waiting a long time (5 minutes) after boot so everything has loaded in the background.
I have an SSD, and the beta-versions
Any pointers?

Any scripts installed?

No Scripts.

If you wait a few minutes after rebooting, then launch Opus, is it slow then as well? Or only right after rebooting?

What about if you use File > Exit Directory Opus (so it's not running in the background), then re-start it?

  1. After a few minutes after booting it has the same behaviour. Window is fast, the initial file-list is slow, maybe 2 - 3 seconds.
  2. After restarting Dopus its fast as usual.

Its really wierd, and I have not installed anything else as for as I know. Maybe an windows update has made its way in.

an nvidia graphics card?
there is something like this with black areas/icons
when the driver is outdated.

in windows, check the thumbnail storage

That suggests something outside of Opus, since it's slow once and then fast the next time, when Opus would be doing the same things at startup in both cases.

Might be some part of Windows that the first run causes to initialise and is then faster the second time it's used.

Could also be something like virus scans of something Opus accesses (wouldn't be Opus itself, as that would happen before it opens the window), or spun-down HDDs spinning up, or similar. Along the same lines, if something in the toolbars/config or initial folder points to an inaccessible network drive, that can be slow to timeout the first time and then may be cached by Windows as unavailable (at least for a while; eventually it'll be slow again).

Process Monitor logs of the slow startup may point to a cause, if you want to try those.

I only have SSD's, and a fair amount of Ram. But I tried to remove Everything (the program) and the slowdown at the start was gone.
So I guess its something about opening the Everything's database or something that made Dopus start slow on my system.
Since I cant replicate it on my other computer, lets put this at rest for now :slight_smile:

1 Like