Admin mode is gone under Win 7 - 64 bit


I have a problem which is very similar to the one in this thread

My DOpus administrator mode is not working anymore. The button for "set admin=toggle" is grayed-out.

I (normally) use DOpus 9.56 under Windows 7 - 64 bit. First I was trying to fix it with rolling back the system to several restore points, but it didn't help and I am not really sure, when the problem was beginning to occur. So I even tried the demo of DOpus 10 to reestablish the admin mode function. But it didn't help either.

dopus.exe / dopusrt.exe (and the shortcut) are not started or running as administrator and not in any compatibility mode. Process explorer shows both files as started via explorer and with medium integrity. dopusx64.exe seems not to run in the background.

I am not able to create a new folder in C:\Program Files with DOpus - no access (5). With Windows Explorer the folder is created instantly and I don't get a UAC message!?!? UAC is activated (normal level).

Any clue what it can be and how to solve it? So DOpus isn't usable in day-to-day life. :frowning:

If the admin mode buttons are disabled it means Opus either thinks it is running on Windows XP (which can happen if it has been configured to run in XP compatibility mode) or the whole process is running as administrator (in which case you can't elevate; that seems unlikely as you cannot create folders in C:\Program Files).

Have you checked that Opus is not running elevated (as admin), and that dopus.exe is not set to run with any compatibility settings?

These two FAQs may help, in addition to the information in the thread you linked:

[ul][li]Why NOT to run Opus as Administrator in Vista / Windows 7
[li]Installer says XP SP3 is required on a later OS version[/li][/ul]

It may also be worth a try to re-install Opus over the top of itself (don't uninstall first, unless you've made a backup of your configuration), in case the components used for UAC elevation don't have their correct registry settings.

Thank you for you reply, Leo.

No, I don't use the XP compatibility mode (or other compatibility settings) and DOpus runs not elevated, as far as I can see. At the end I was installing the DOpus 10 test version on top of the registered DOpus 9, thinking that this would reset some registry settings. But no change.

I'll try it later to deinstall DOpus 10 and to install DOpus 9 again. But after reinstalling some restore points with no luck I don't have much hope. :frowning:

Have you checked the compatibility mode settings? Windows can set them in some situations without making it obvious that it's doing so, unfortunately.

Did admin mode work for you in Opus 9?

Make sure you reboot when prompted to by the uninstaller/installer, too.

I deinstalled DOpus 10, rebooted, installed DOpus 9 then, rebooted and the problem is still there. :open_mouth:

I also checked the compatibility mode (again): nothing. Originally the admin mode worked for me throughout all those years with different DOpus versions on different Windows versions. The problem began some days ago. Hmmm...

It's a little strange that I'm not able to create a new folder in "C:\Program Files" with DOpus, but get a UAC message when I try to delete this new folder in DOpus. I forgot to mention this before.

Do you try what resolved it for me (I had the original topic you referenced). Give administrators permission to c:\users{your login name}.

Today I was booting up the PC again and couldn't believe my eyes: the admin mode is working again! :thumbsup:
So I think deinstalling the former version and reinstalling DOpus 9 did the trick - strangely I had to boot two times after that...

Thanks for the tips, Leo and sfuller!


I do have the SAME problem. I've tried all suggestions above. None worked. Even installed latest beta (

Opus is not running elevated (e.g. I'm not able to create a folder in C:\Program Files, there's no UAC prompt, windows simply refuses to create it), it has not been configured to run in XP compatibility mode. OS is Win7 pro 64bit.

It's weird.

Is the Preferences / Display / Transition Animations page visible for you?

If not, something is making Opus think it is running on Windows XP. (When you say it hasn't been configured to run in XP compatibility mode, have you checked that's the case or do you just mean you don't remember configuring it explicitly? The setting can be added implicitly.)

Preferences / Display / Transition Animations page is visible.

When I say it hasn't been configured to run in XP compatibility mode, I have checked that's the case.

When trying to create a folder in C:\Program Files, windows prevents me from doing so. But dopus IS ABLE to delete a folder that I've created in C:\Program Files with windows explorer (explorer of course prompts if I want to do so). When deleting Dopus uses UAC ...

Correction: Dopus is NOT ABLE to delete a folder within C:\Program Files, it is only able to send it to recycle bin. The windows prompt shows up that I have to confirm the deleting, THEN UAC opens and asks if dopus should proceed.

When trying to delete it directly, windows just says: access denied.

Conclusion: Reinstalling Windows ...
Hope dopus won’t forget that it’s running on Win7 again.

If that Preferences page is visible then Opus knows it's running on Win7 (or Vista, which also has UAC), so something else is going wrong.

It's hard to say what might be causing the problem, though, since it's not widespread or something we've ever seen ourselves.

If you still have problems, open an official support request and GPSoft might be able to suggest a way to diagnose what's going wrong (e.g. provide a test program that detects if UAC elevation is possible in a similar way to Opus itself, and outputs diagnostics). That could be a time-consuming process but I can't think of a better way to work out what's going wrong.

Is your secondary logon service running?

Thank’s for all your advices. As I’ve already reinstalled Windows it’s working well for me at the moment. I hope this problem won’t arise again.

Here I am again - the problem did arise again too, all of a sudden! :unamused:

The tricks did not help, 2 x rebooting did not help. Secondary logon service is normally not running on my system ("manual"), but starting it and closing/restarting DOpus did not help either. I did not reinstall DOpus 9 until now, but I cannot imagine, that this is the solution... Hmpf...

Again I don't know the exact moment when the admin problem appeared. I often use hybrid standby, so one session can virtually take a very long time. Before I remarked it I used "normal" standby mode a couple of times. Nothing more unusual what I could remember.

This time it took not long to find the solution:

My UAC was changed (probably due to the last Windows Update) to the highest level. Seems to be a problem with DOpus. I changed it one level down and after restarting DOpus the admin mode worked again. :stuck_out_tongue:

That isn't the problem. I've had UAC set to the highest level (the only level that actually makes a difference IMO) since Windows 7 came out.

Is there anything unusual about your account setup, or any security tools that you have installed, or anything else you can think of?

Windows Update would never change your UAC level so finding whatever did change it is probably the key to understanding what's going wrong.

No, nothing unusual and I did not change anything in this area.

Yes, of course. I keep watching it and will post if I discover anything new.


I think I do have the same issue - noticed it when I was trying to copy a file to a folder in C:\Program Files (x86) ... Opus just shows an error "access violation" - no UAC is coming up.

The "transitions" menu in preferences is available - so obviously DO knows it is running on Windows 7 (here 64 bit too - german localisation).

I had the same issue some days ago when creating a custom button that was supposed to use admin rights - and did not work. Last time a reboot resolved it - but this time the issue survived a reboot. Windows explorer can copy a file to the same folder - obviously requesting UAV elevation.

I have no clue what could be causing this ... but looks like there is something related to DO that makes it not request the needed user rights.

Regards - Peter