Batch file rename over a network folder or NAS does not work

There is one annoyance related to batch file rename:

When renaming a batch of files and using one of the existing options, say to "capitalize all words", it will work ONLY when in a local hard drive. However, if I do the same for files stored in a NAS... nothing happens. I copied the batch of files after renaming them (using the "capitalize all words") to a folder in drive C: and the files names were still not capitalized (thinking that it has to do with the way the NAS handles files). I read through this forum and I've tried all suggestions, even updating the NAS... nothing works. Any ideas?

I updated Dopus to the latest as of today, 2019-07-12... and still the same glitch.

Again, selecting a group of files in a network folder or NAS, then clicking on the button "rename" on the toolbar, then under "Actions", I selected "Modify Capitalization" and I picked "Capitalize all words"... nothing happens... no matter what other capitalization option you select, it does nothing. Also, I try with "OK" and "Apply" and nothing... It does work when doing it in a local hard drive though.

Is the NAS running something other than Windows?

It probably ignores case-only renames. What happens if you do a similar rename on a file from Explorer?

Check if the NAS has an update, and complain to the vendor if not.

Thanks for replying Leo.

By the way... I've tried and seldomly used now (thanks to Directory Opus) Total Commander, Speed Commander, and File Boos (I used many others but not worth mentioning) - they are still installed in my computer. Directory Opus is years ahead of the rest.

Now, Explorer has absolutely no problem with renaming batch files (using the F2)... lower case, upper case, etc.

Also, Directory Opus only has problems with batch files with the NAS... individual file renaming on the NAS is not a problem. Individual file renaming DO retain the new changes when doing one file at a time... it's only when using the "Rename" button that will not do anything.

NOTE: renaming a batch of files and adding a custom change with Directory Opus is not a problem either and it does retain the uppercase, lower case, etc (doing an inline rename of files, where you manually type a new name and all other selected files also are added the new info)... I mean, instead of using the "Actions" section...

The NAS already has the latest update (firmware, etc.)... the only thing left to try on the NAS side is going to an older firmware and see if one of them works... painful. The operating system on the NAS is a version of Linux. I'm using a QNAP NAS. I have also tried with other NAS brands like Synology and it's the same problem.

Batch renaming is done the same way renaming individual files is done: One MoveFile call per file, with the old and new names passed to it. The NAS should not see a difference, other than in how fast the renames are happening.

A quick test against a network drive here works fine as well.

Could you post a screenshot showing how you have the Rename dialog set up, ensuring we can see the preview of what will happen at the bottom of the dialog?

A Process Monitor log of what happens when the batch rename is applied may also reveal what's going on.

Have you tried refreshing the folder (usually F5) after renaming the files to see if they're being renamed but the change notifications are not reaching Opus?

Please see attached files.

The first file is before attempting to apply a batch rename.
The second file is inside the Rename dialog box with the options selected.
The third file is after the process was completed and files were still unmodified.

I also sent a dropbox link of the log file to The file was too big for the mail server.

I've seen this myself in the past on a NAS device. It's not the batch rename per se that's the problem, the key is that all the rename is doing is changing the case of the existing filename. Some NAS implementations seem to reject a rename operation when all that changes is the case.

If you try that form of rename (only change the case of the existing name) you should find that it happens when renaming an individual file as well (and also in other programs, I would assume).

You are right... I've seen the same...

In this case, I'm wondering if you could add a feature then:

Have it so that (a check box option perhaps) when doing a batch file rename, Directory Opus adds something at the end of the file names, say a blank space or a character of my choosing. Then I can easily go back into the rename window and manually remove the blank space from all my hundreds of files all at once. It's a two step process but it will happen within five to ten seconds tops.

I have thousands of files (per batch) in network folders that must be rename (sometimes to all upper case, sometimes to all lower case, and sometimes to capitalize each word, etc.) and right now I have to first copy them to a local hard drive and then copy them back... this is painful and so slow...

I hope you can help with this feature request then.

Thank you Leo.

I do already have this on the list to look at in the future.

An easier thing for you at the moment, rather than copying the files off the network and back again, would be to run two separate batch renames. Run one that changes the case and adds a letter to the end of each name (e.g. * -> *x), then run another one to remove the letter (*x -> *).

Of course you could also complain to the NAS manufacturer since fundamentally it's a bug in their Samba implementation.

Leo, Jon...

Thanks Jon for the suggestion... I'll do that in the meantime.


This is why I asked:

Or does a case-only rename work in File Explorer? (It's possible Explorer has some kind of mitigation for this, perhaps.)

You should also complain to your NAS vendor as this is completely incorrect behavior for an SMB device. SMB should be case-insensitive but also preserve case. This will cause problems in other software was well, even if workarounds can be added to individual apps like Opus or File Explorer.

Seems every other NAS the various vendors make has its own set of random bugs and regressions, rather than the software they use maturing over time. I don't really understand why, but it seems to be how things are. One reason I use Windows machines!