Cannot open jpg-files with double click (Win 10 Creators Update)

A couple of days ago i updated Win 10 Pro x64 successfully to the latest Creators Update. After that i decided to set Directory Opus (12.4 x64 #6288) to replace Windows Explorer.

Now if i double click on a .jpg-file in Dopus i get an error message:

The default app for jpg-files are set to Photos v17.313.10010.0 and if i change it to let´s say Photoshop i can double click the file in Dopus and open it in Photoshop. However, if i change back the default app to Photos the same error occurs.

I can open the same files from within Windows Explorer and jpg-files now opens in Photos.

FYI, Photos is the default app included in Windows 10.

Am i alone in seeing this error or do anyone knows how to solve it? I don´t know if i had the same issue before the Win 10 upgrade since i used Windows Explorer as my main file explorer.

/Roger :slight_smile:

1 Like

It seems to be a problem with the built-in Photos metro app in Windows 10 Creators Update. If you make double-click use the Opus viewer, or just about any other viewer, it should work OK.

For the Opus viewer: Use the Opus image viewer inside or outside of Opus.

We'll look into things and see if we can find a fix for the Photos app on our end.

I do not believe this is exclusively a Windows 10 Creator's Edition problem I have had exactly the same problem in earlier versions of Windows 10. It proved an incredible nuisance and almost impossible to solve. Adobe suggested re-naming the photoshop.exe to say mynewphotoshop.exe and associating with the renamed program. It worked after a fashion, but was hardly a real solution.

After days of messing around I threw in the towel and did a clean install of Windows 10 and photoshop, which is drastic, I know, but the problem has not returned - evan after updating to the appallingly named Creator's Update.

Somebody told me the problem is caused by some security Microsoft has introduced to stop applications getting control of certain file types. Well, Microsoft - it works. Thanks alot!

1 Like

Leo, that seems to work ok for jpg-files but one side effect is that the Opus viewer also opens .psd files from Photoshop, files that i really want and need to open in Photoshop.

So, is there a way in Opus Preferences to filter out files such as "open jpg-files in Opus viewer" and "do not open .psd and .tif files in Opus Viewer, use system default"?

It would be great if this, the issue with opening jpg-files with Windows Photos, could be fixed in Opus. :slight_smile:

Yes, leave everything as it is but then go Settings > File Types and edit the .PSD file type in the bottom section of the list.

On the Events tab, set Left Double-Click to run this:

FileType ACTION=open

That will effectively un-override what happens in Opus when you double-click PSD files, while keeping things the same for the other file types the viewer handles within Opus.

It won't affect anything outside of Opus, which I assume is still working as desired for .PSD files.

Leo, yes that worked as expected! :slight_smile:

Regarding the initial issue with the error message i got i noticed the following yesterday:

  • I installed Opus on my laptop wich had not been upgraded to Creators Edition. Opening jpg-files from within Opus opened them in Windows Photos. (success)
  • I then upgraded the laptop to Creators Update. I could still open jpg-files with Opus. (success)
  • Next thing i did was to launch Windows Explorer to open the same jpg-file. Now i was promted to select the default app for jpg-files and i choosed Photos. The file opened in Photos as expected. (success)
  • Now i got back to Opus and this time, after i had set the default from within Win Explorer, i got the very same error message i reported in my initial post. (fail)

It seems that there is something that goes "wrong" when one assign Photos as the default app for jpg, png, etc from within Windows Explorer.

Both computers use Win 10 x64. My desktop use Professional while the laptop uses the Home version.

I noticed this difference as well: In Explorer i have the option to open the file in Photos while in Opus i the nearest i find in the menu is Photo Gallery Viewer. I see the same at my laptop as well.

1 Like

Photos and other "Metro" apps have never appeared in the context menu in Opus.

They can't, as their names are randomly generated in the registry (e.g. AppX47jwqdafzcxw9wm0mbb5cev2eav5b1je appears to be is the Photos app) and the human readable versions of their names are inside resources that there is no (public/documented/known) API for reading from the desktop/Win32 side. (Unless an API has been added since I asked an expert on the area some time ago. If an API exists we would gladly use it, of course.)

The names do appear if you go into the Open With dialog, since that comes from the Windows shell (Explorer).

Sometimes Microsoft forget that anything other than the shell/Explorer may need to know details such as the names of other programs.

It's been this way since Windows 8.0 introduced Metro apps. Few have noticed over the years, I think because it's rare to want to use a Metro app. :slight_smile:

Double-clicking is still OK since we don't need to display the name of anything in a menu for that, we can just send the double-click to AppX47jwqdafzcxw9wm0mbb5cev2eav5b1je or similar behind the scenes without needing to know it's human-readable name.

The Photos app has been a bit unusual for a while now, since if you launch it from Explorer it gets a next/prev list of other photos in the folder, but if you run it from anything else you didn't get that list. My assumption is that Explorer is launching it via a special API that can pass a list of other files in the folder to it. It also supported the standard API so that it would work when launched in other ways. In the Creators Update it appears that its support for the standard API has been broken. But this is just a guess as it is hard to know exactly why it isn't working. We still need to investigate more on our side as it's always possible we're failing to do something which only the Photos app needs.

1 Like

As I said in my earlier post, there is a sense of deja-vu in reading about your problem. Your Window's registry is possibly screwed up. I came across other people with the same problem, and some "gurus" who offered suggestions on how to unscrew it.

None of them worked for me, but you may have more luck. I became so frustrated with the problem as I spend my life opening jpg files in Photoshop that I reinstalled Windows and Photoshop. That as the only thing I found that would fix this perky problem on a permanent basis.

If you do not want to go to all this trouble, try the suggestion Adobe gave me. Copy the Photoshop executable with a new name and associated jpg files with the renamed executable. It should solve allow you to open jpegs, but will not fix the damaged registry.

Good luck with this one, you will need it.

Photoshop is a normal Win32 app, so what you saw with that is probably not the same thing that's happening with the Photos app.

I can confirm that the Photos app isn't launching properly on my own machine after the Win10 Creators Update, while everything else still works fine. Whatever is wrong seems to be specific to the Photos app, and is probably not the same thing you saw with Photoshop on your own machine.

I wouldn't recommend reinstalling Windows over the Photos app, at least not yet.

The scenario in Roger's first post is exactly the scenario I experienced. As I said the only way to remove the error message after changing the default program to the Photos app was to rename the Photoshop executable and associate JPG files with the renamed program. (Adobe were suggesting this as a fix for the problem)

By the way, Photos app works perfectly fine on my machine with the Creators Update.

I did find a web page which gave a long and detailed explanation of the problem. Unfortunately I can't re-locate it. Much of it went over my head but the gist appeared to be that Microsoft had done some work to stop the hi-jacking of jpg files by rogue programs. It involved registry entries - I seem to recall that hashing or some such thing was involved - which apparently had the habit of getting screwed up, and causing the problem that produced the error message. The writer of the article claimed that

I ran with the renamed Photoshop executable for a few weeks, but decided that with the Creator's update on the way I would like t o start with version of Windows 10 that worked as advertised.

I do suspect that Microsoft has done a lot of work on its Apps for the new update. Before Creators, I could never get Groove Music to work properly, now it works like a dream.

We have a fix/workaround on the way for the Photos app in the Windows 10 Creators Update.

It will be part of the next beta release, assuming no problems are found in our internal testing.

1 Like

That´s really great news, Leo! :slight_smile:

I just downloaded the latest version of Opus and now Photos do open up .jpg files. :slight_smile:

The issue now is that the Previous and Next arrows in Photos are greyed out when i open files with Opus while they are fully functional when i open the same files with Windows Explorer.

IOW, if i open a jpg-file in Windows Explorer i can use the arrow keys on my keyboard to show the previous or the next image. If i open a jpg-file (the same file) in Opus i can not use the arrow keys to show previous/next.

On the attched image you can see that the left/right arrows are greyed out. Why does this happen when i open the jpg-file from within Opus? :slight_smile:

The Next/Prev behavior has always been that way in Windows 10, and is outside of our control. It is something Microsoft have chosen to do for their own unfathomable reasons.

The Windows Photos app chooses to do things differently depending on how it is launched, and there's no other documented way to launch it that we are aware of, as with a lot of the "Metro" side of Windows.

See my reply here for more detail.

One of many reasons to avoid that style of application, as they tend to be very inflexible for use in any way but the ones Microsoft want you to use them. (Similarly, there is very little information about how to run the Photos app via the command line if you want it to do something more than just open a particular file. It is not a good photo viewer.)