"Can't find device" while syncing

OK Leo. I have installed the latest version. The syncing process was still disrupted and erratic. I'd now be grateful for your suggestions. Regards, MS

Have you tried everything above?

I can't see anything above, Leo. What are you referring to?

Where (in the name of God) is this count of new replies. Nothing that I can see refers to my question. Are you simply pointing me to a list of FAQs?

This was from my message above:

  • Trying a different USB port or USB cable is another thing that may help.

  • Also make sure you have installed the motherboard chipset/USB drivers for the machine (usually from Dell's website), as the generic ones may not work properly.

Another thing to try:

  • Set Preferences / Miscellaneous / Advanced [Filesystem]: copy_buffer_size to 64 KB (this will slow down normal file copies, but can fix things for some bad USB devices that fail with larger buffer sizes).

Please also link your account, or one of them at least. (I am assuming ms138 and sonenscher are the same person; apologies if I'm confused here.)

Yes. I am ms138 and Michael Sonenscher. Your user interfaces are too cluttered and too hard to make sense of for me to see where or how to establish a link, or to do much else. I will try to do what you recommend with setting the preferences. Regards Michael Sonenscher

You just need to click the link I gave you and paste your registration code into the box where there is an example registration code. It's very simple.

I have now made the link. No need to reply because the syncing problem centres on my Dell laptop at work and I will not be using that computer until my Tuesday. I will also try to find the right drivers from Dell for the USB ports and motherboard. MS

1 Like

I have a recurrent problem with Dopus on my Dell Inspiron using W10, which is that Dopus can't find my external hard drive to sync files from the computer to the external hard drive. Why? What can I do? This never happens with syncing the same external hard drive to my computer at home (also a Dell, but an older laptop whose name I can't remember offhand)

Can you see the drive under This PC (aka My Computer)?

Does it appear as a normal drive there, when looking in Opus and File Explorer?

Yes. I see it, but then the device drops off and comes back at high speed. Very often. M

Does it do that in both programs or online one of them?

How much have you tried to do with the drive using File Explorer on the same computer that's having problems? Is it able to copy a large amount of data to and from the drive, i.e. not just see it but use it in an operation that takes a minute or more?

I use Dopus not File Explorer to access the drives. It is never possible to copy a large amount of data easily to and from the drive using Dopus. Why?

I'm asking if Explorer has the same problem.

If it does then the problem is not with Opus but the hardware or drivers for the drive or USB, or a loose cable or something, but not Opus. If the hardware isn't working properly, and the drive is constant appearing and disappearing, then it won't matter which program you use to copy the data.

1 Like

As usual, the problem is not yours because the fault, as usual, is always someone else's. Well done. What a diagnosis.

Don't be silly, that wasn't a diagnosis, it was a request for information.

Leo is simply asking you to look in Explorer and see if you see the same thing there.

What's unreasonable about that?


Apologies for the delay in getting back to you. The problem occurs on my computer in my office and I wasn't in it over the weekend. To reply to your question. The problem does not occur in Explorer because I do not use Explorer to sync files. The problem occurs with Dopus which I do use to sync files. If I look at the contents of my external hard drive in Explorer, all the files are always visible. My problem is that the external hard drive drops off, crashes or gets lost when I sync files using Dopus. Why? What should I do to prevent this happening?

Please try using Explorer to copy a similar amount of data and see if the problem occurs.

OK. I've now had time to use Explorer and Dopus. The external hard drive gets dropped intermittently when I sync using Dopus, but it does not get dropped with Explorer. So, it looks like this is a problem with Dopus and its interaction with Windows on my Dell Inspiron (the problem doesn't occur with the same software on the older Dell machine I have at home). All hard to explain. Any advice?

Try setting Preferences / Miscellaneous / Advanced [Filesystem]: copy_buffer_size to 60 KB. Some USB devices have problems with larger buffer sizes, and that might be causing it to disconnect all the time. (If it doesn't help, reset it back, since it can affect copy performance.)

Opus only calls high-level APIs like CreateFile, ReadFile and WriteFile, so if the drive keeps disconnecting it's going to be a fault in the drive or USB device/driver it's connected through. There's nothing in Opus that would disconnect a drive, short of the Eject command being run. But we have seen USB devices that don't work properly with larger buffer sizes (as well as ones that don't work with non-buffered I/O, but that's off by default and you'd know if you had turned it on), where the devices were apparently only ever tested against the buffer sizes Explorer uses.

I would also check in Event Viewer under Windows Logs > Application and Windows Logs > System. There may be Error or Warning events in there coinciding with the times of the disconnections, which could give more detail on when or why the disk is disconnecting.

If you can capture one of the disconnects with Process Monitor we could look at that to see if it reveals something as well. A similar log of what Explorer does with the drive could also be useful for comparison (that would tell us the buffer size Explorer is using, for example; it varies by device and connection type).