Change refresh on drive mounted via linked directory


Using Directory Opus Pro (4683) x64 on Windows 8 Pro x64

I read some posts about that problem but none solution given worked for me.

USB HDD don't refresh pane after deleting a file.

Anyone can provide a working solution?


Please see Changes to folders are not being detected.

(If that is one of the things you've already read and found didn't help, what do you see from the debug mode it tells you to try?)

Hello Leo,

yes the link provided points to the documentation I stumbled upon during my researches.

The DebugView output is quite poor:

[1356] [1344] dopus: ShellChange: 000000000896F2E0, 3
[1356] [1344] dopus: ShellChange: dwEvent = 40000
[1356] [1344] dopus: Notify 0000000003FA5F10 Returned 114 bytes, error 0

And I really don't have a clue how to take any valuable information from it.

Any help would be appreciated.

That suggests the USB device is not generating change events properly, as you should see more than just those ShellChange events.

Do other programs (e.g. Windows Explorer) detect changes on the drive correctly?

What happens if you fully exit Opus (don't just close the windows; use File -> Exit) and then start it again and look at the USB drive?

OK, make sense as it is the problem

Yes, they all do behave correctly as wished (explorer, xplorer2, xyplorer)

Same behavior

What kind of USB drive is it?

Does it appear as a normal drive letter?

[quote="leo"]What kind of USB drive is it?

Does it appear as a normal drive letter?[/quote]

It's on a extenal dock: ... Dock+DD-01
and this happens to this one too: ... 388&sr=1-1

xplorer2 and xyplorer does work flawlessly with inserted drives and not DO.

It's definitively a Directory Opus bug.

Does it appear as a normal drive letter?


It's not mounted as a drive, but is directory linked. So the problem is from there.

But others file managers i cited do all work as this, no need to link my drive to a drive letter, linked directories are well used.

So, what's wrong in DO??

How do we mount a drive in the same way to try it out? Can you tell us the steps so we are testing the exact same setup?

Yes, PM'ed

Anyway, tweaking special buttons with GO refresh=source is a quite boring but working temporary solution.

Hope you'll fix quickly that bug/misbehavior

Thanks for the PM.

The extra details (that have been requested be kept private) look important and may change things considerably.

We will look into it.

Just annoyed the only filemanager I really use is the only one
to misbehave in my setup.

The others works normally as previously said (XYplorer, xplorer2) but I don't use them more than once a week or so,
and DO is the first opened app in my laptop.

I eager to have it work again. Maybe i'll try to reinstall version 9 to test if the bug is present.

Have you tried this in other file managers?

I'd link your account to get higher priority on this. Right now, with your account not linked, I'm sure this is lower on the list of the many things they are actively working on.

Previous post: The others works normally as previously said (XYplorer, xplorer2)

Maybe you posted while i did...

Oh right, I hadn't noticed you mention that...

Hmm..maybe i can elaborate to help

The others work normally as previously said (XYplorer, xplorer2). xplorer2 is x64 too.
Both contenders work in refreshing file pane as soon as I delete a file.

This is where DO fails : It occurs on deletions, either by delete command or by moving files to other location too.

And for the weird thing than maybe can help to debug, I have a custom right menu handler on every files/folder to secure delete files.


That way would ALWAYS work, i.e file deleted that way diseappear from file pane, and focus jumps to next file, as expected.
Maybe it can steer you straight to solution.

If you delete the file in another program (or a DOS prompt), does it vanish from all the other file managers? Or does it only go from the one which actually deletes it?