Choose default columns for Details view

How do I select default columns for the Details view ?
My default view is List, but when I occasionally (very rarely) switch to Details, I would like to see a given set of columns.
(In particular, I'm after the "Type" column: I would like to never ever see it ever again for the rest of my days. Ever.)

Thank you. I saw that FAQ, but it is not clear how it would solve my problem :
The "save for all folders" option saves the Details view as default, which is not what I want. I use List view as default and occasionally switch to Details.

After testing, the solution turned out to be:
1- Switch to Details view
2- Select desired columns (and columns widths, as it turned out)
3- Save for all folders (this changes the default view for all folders, not what I want)
4- Switch back to List view
5- Save again for all folders

Now when I occasionally switch to Details view, I have the columns selected at step 2, which is what I wanted.

Not exactly transparent in the FAQ entry.
Hope I'm clear.

You could skip step 3. (And step 1, if you add the columns within the Folder Options dialog.)

Nope. Skipping step 3 works for the current folder only. I want the "Type"-less Details view to be the same for ALL folders (if and when I switch to Details on occasion).

Step 5 overwrites what was done in Step 3 so it shouldn't be necessary to do Step 3.

Nope again. Just tested 1-2-4-5. It's a simple test you can do yourself : the selected columns at step 2 stick for the current folder only, unless you do 3 as well (which also makes simple logical sense, you want ALL, apply to ALL !)

Your steps said you were saving for all both times.

I have, and it works as I said:

Got it. That is not what I'm doing. Here is what I'm talking about :


Did not save for all foders


Save for all folders


I do not select columns in the Folder options, I do it in the lister directly, and then use Folder options to just save.

If you change "Did not save for all folders", to "Did save for all folders", it sticks.

Switch back to List mode before doing the save for all folders, if you want all folders to be in List mode.

You only need to save once. It doesn't matter whether you change the columns, or the display mode for that matter, in the file display or the Folder Options dialog, as long as you make the changes you want before saving.

Switch back to List mode before doing the save for all folders, if you want all folders to be in List mode.

From my post above :


My screenshots show you the Type column creeping back despite doing exactly what you're saying.
If I don't also save after modifying the columns, it does not stick (for all folders). There has to be two saves. My series of screenshots shows exactly this scenario.

I only saved once in my video. I don't know what else to say. As long as you have a method that works for you.

My thoughts exactly : what else to say + what matters is that a solution exists.