Columns won't show in desktop, just "name."

In the column listings, I cannot manipulate the column heading in Desktop. I have set and reset the Desktop Folder options several times. The other folders follow the format I set in options, but not Desktop folder. It insists on showing the date modified first no matter hwat I do. If I try to drag it one way or the other, the folder then just shows the filenames. Thanks for the help.

If you want all folders to use the same columns, have you followed the main guide for that?

To get this to work, don't forget in the Desktop Folder Options dialog to change the width to "collapse." (I did this with "filename, left others on "auto" and everything lined up nicely.) Took me a while to understand that you can set both universal preferences and folder preferences. A whole lot under that hood.

The "collapse" resizing mode is completely optional. The video at the bottom of the guide I linked explains it in detail, if you want to learn more about it.