GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Context Menu Item for Picture Files


#1

Using V12.5
An item is appearing with a very long name, which opens MS picture editor (see screen shot).
Windows explorer shows this context item as “Edit with Photos” (see screen shot).
Can I do something to either change the long name in DO, or delete that item (I never edit in MS Photos anyway)
Cheers
Gary


Win 10 Creators Update 15063. Context Menu entry too long
Help with Opus Context Menu
Big shortcut name
Weird item in context menu of image
#2

It will be in the registry but there are many places it can be, unfortunately. Searching for the string that you see in Opus using Regex.exe may be the quickest way to find it. (Just make sure you skip over things which are similar but not identical to it.)

Do you know how it was added? I’d like to take a look on my machine but don’t have the same menu item, and can’t see an option to add it inside the stock Photos app.


#3

Thanks Leo. I’ll give that a try, after I backup the registry of course. Strange though that it’s happening in DO but not in Explorer.


#4

Hi Leo. Changed the 1st occurrence of the string that I found, and bingo… it worked!
Thanks for your help.


#5

Will there be an update to fix this without everyone having to edit their registry? I was also able to edit my registry and reduce the description length.

The problem is in the Windows integration portion when a graphics image (JPG, BMP, GIF, etc.) is right-clicked. The long description is for Windows 10’s Photo app.

But now that some have edited their registries, will a patch affect those who have changed the description of this item in the Windows registry?


#6

So far these are the only two reports of the problem, and we are not seeing it on our own machines which makes it hard to work out what’s happening.

If you have any idea how to make the problem appear, please let us know, and we’ll look into it.


#7

It just appeared in the context menu the next time I opened Directory Opus. One day it wasn’t there and the next day when I opened DOPUS, it was. It has to do with the Windows Integration and I don’t know what caused DOPUS to suddenly add that Windows 10 app. Perhaps, DOPUS read the registry and discovered it as a new Windows item to integrate. It’s also interesting to note that after I edited the app’s description in the registry, that same custom description now appears in Windows 10’s File Explorer. And the app that opens from the context menu does not look the same as the Photos app from the Windows 10 Start menu. The app that opens from the context menu allows more editing options and looks like a different app, although both are named “Photos.” If you have an address I could send screen shots, I could send one of the Photos app from the Start menu and one from the app that opens in the DOPUS context menu.


#8

It’s not there for me and I have all the (non-beta/insider) Windows 10 updates installed. Perhaps it’s tied to an optional component that was turned on, or an app from the Windows Store?


#9

I hadn’t made any changes to my DOPUS configuration prior to this appearing, and I have all the Windows 10 updates plus I have not downloaded any extra apps from the App Store. It’s a mystery how this only shows up when a graphics file is right-clicked on, either in DOPUS or Windows File Explorer.

But I just learned something – this is the same Photos app that is in the main Start menu, but when an image file is right-clicked on it opens the Edit portion of the app – the same Edit part of the app that is opened when a picture is selected in Photos and the Edit option at the top of the window is selected. It’s not two different apps, but two different parts of the same app. Interesting.

Also learned that graphics files are associated with the Windows 10 Photos app by default. Associating graphics files with a program other than Photos will eliminate the long context menu item and solve the problem without having to edit the registry.


#10

Hello,

Sorry to wake up this thread, but this is now happening to me on two different machines. On one, I have the long menu like in the above screenshot. On another machine, the menu item reads “msresource:EditWithPhotos”. Clicking these links opens the Photos app in edit mode. Trying to search the registry, I find dozens and dozens of matches. if anyone knows which registry entry/entries to fix, please post it.

This behavior seen using Opus 12.5.0 and 12.6.0. I have Opus’ Windows Integration turned OFF (i.e., not using Zip handler or Viewer directly; I have custom toolbar buttons that fire Opus’ commands when I need them, otherwise I let Windows handle the items.)


#11

I was able to resolve this issue. I have seen this issue on 4 of 6 Win10 machines. All the 1703 builds have menus that look like the screenshot above (@{…etc…}), and all the 1607 builds have a menu item “ms-resource:EditWithPhotos”. The remaining 2 machines do not have the new “Edit with Photos” or “Edit with Paint 3D” menus that were recently added by MS in their latest updates (not sure why, as all are up to date).

The attached reg file fixes the menu item; remove txt extension and run… But check your registry first, as the random application name that UWP apps use may change at a later date. This reg file appears to resolve issues with Win10 1607 and 1703.

.FixEditWithPhotos.reg.txt (225 Bytes)


#12

What’s the build number there. Is that the Windows build or something else?

Mine’s a very different number:

We’ve still not seen this on our own machines but would like to know how to make it happen so we can look into it properly.

(I expect the fix will be for Opus to hide the menu item entirely, as Microsoft do not provide an API for looking up strings in ‘metro’ apps, unless they added/documented one recently.)


#13

Win 10 version/build numbers have me totally confused.
My System Information window shows 10.0.15063 Build 15063 also
BUT
Going to Settings,Display…/About - mine shows Version as 1703 & OS Build as 15063.413
What does 'Version" actually mean? and likewise “OS Build” - just MS being difficult?


#14

Leo,

My Version 1607 machines are build 14393.1358.
My Version 1703 machines are build 15063.413.

Hope this helps!


#15

Thanks, hadn’t seen that, and the same OS version wasn’t in the old style System control panel. (Windows is such a mess these days…)

I’m on Version 1703, Build 15063.413 in that case, and was not seeing the extra menu item.

But after associating the Photos app with a file type, I am seeing it now. (I’m sure I tried this earlier but didn’t see it, so it may only happen with a combination of the Photos app being default, and a recent OS update.)

Setting something else as the default for the file type also gets rid of the menu item again, which is rather strange and non-standard. But also a quick way to fix things, unless you really want to use the stock Photos app.

Now that we’ve seen it on our own machines, we should be able to add some kind of fix or workaround for it.

Many thanks to everyone for providing info in this thread.


#16

My original fix (reg. edit) from June 4th, stopped working today. Have no idea why. Hope a fix for this problem won’t too far away.


#17

The easiest/quickest fix for now seems to be to associate another program with double-clicks on the filetype with the problem. (e.g. Open With, Choose Default Program, Always Use This App…)

But if you search the registry for the string shown in the menu you should find the thing to edit; maybe it has moved place for some reason.


#18

This will be fixed in the next update - editing the registry will no longer be necessary.