Crash when right-clicking

I use Dopus 11 and in one of my photo folder I have a zip file. Everytime I right click on it to unzip it (using 7zip) Dopus crashes. I only managed to solve this out by pasting zip file on my desktop and unzip it from here. What's wrong with that? Could it be an issue with 7zip?

I've been doing some other tests and it seems that the crashes occur whenever I right-click in a folder with images in it, not only with zip files.

Please see this troubleshooting guide: Crash, exit or high CPU when right-clicking certain files

DO crashes whenever I right click on a zip archive.

Win 8.1 Pro
Director Opus 11

Thank you for pointing out topic 1395. However there is no mention of DO 11. Furthermore this behavior did not occur in V10 or any of the subsequent versions from 8 on (then obviously not on Win8).

As a paying customer I would expect a bit more than just a 9 years old long winded guide that starts with a workaround and then basically says "we don't know what causes the crash, you may try any of these 5 to 10 routes".

The reason why I use DO is to save time in my workflow. Crashes cost time. Having to hunt down a plugin costs time. Time that I do no have. Please be so kind to provide proper support, based on the current version 11, with some results from your beta tests.

Thank you very much

As a matter of fact, this topic 1395 gave the solution, it was notepad++ extensions who was reponsible for crashes. I have followed the procedures described in the topic and everything is now back to normal.

Great find Ghadzoeux, I am using Notepad++ as well.
I still don't know how deactivate it - I don't even know what exactly to deactivate.

I would recommend to follow the instructions in the mentionned topic, it's quite simple and fast :slight_smile:

Thank you Ghadzoeux, I realise that you are fellow DO user just trying to help.
I'd much rather wait for an official answer from support that tells me what to do.
In topic 1395 there is no information about V11 and nothing about Notepad++.

Kind regards

The guide Ghadzoeux pointed to is the official answer. That's what to do.

(Oops, I got the two names mixed up before.)

Thank you Leo.
I do not understand that guide and request support.

to put it more specifically, I do not get any what you call " CLSID strings".
I get Number, Time, Debug Print.

The debug output (that will appear in DebugView, in the Debug Print column) should look like in the guide's example, with things like this:

CLSID: {8DD448E6-C188-4aed-AF92-44956194EB1F} (WMP Burn Audio CD Launcher) CLSID: {7850a720-705f-11d0-a9eb-0080488625e5} (BestCrypt Shell Extension) CLSID: {8D9D4D0D-FDDD-44CB-AAB2-6161FA0757C5} (IZArc Shell Context Menu)

The things in {...} on the lines starting with "CLSID:" are CLSIDs.

Each CLSID identifies a particular shell extension, like an ID number.


[quote]A Class ID (CLSID) is a 128 bit (large) number that represents a unique id for a software application or application component. Typically they are displayed like this "{AE7AB96B-FF5E-4dce-801E-14DF2C4CD681}".

You can think of a CLSID as a "social security number" for a piece of software, or a software component.[/quote]

This is the kind of output that I get. And a search for "CLSID" returns no result

[1340] ===================== [1340] [1340] ===================== [1340] Property::GetValue(key) Exception, Key= 68|0|32 [1340] [1340] ===================== [1340] [1340] ===================== [1340] Property::GetValue(key) Exception, Key= 68|0|32 [1340] [1340] ===================== [1340] [1340] ===================== [1340] Property::GetValue(key) Exception, Key= _TRASH_COMMAND [5716] OnEnter 1/3 [1340] [1340] ===================== [5716] [5716] ===================== [5716] Property::GetValue(key) Exception, Key= KEYEVENT_BLOCKING [5716] [5716] ===================== [5716] OnEnter 0/41670736

That's all coming from another program or component. Other programs can send things to DebugView at the same time as Opus. (It's bad form for them to do so, when not switched into a diagnostic mode, but nothing stops sloppy apps/components from doing it.)

Have you enabled context_menu_debug in Opus?

With that enabled, and DebugView running, have you right-clicked a file?

If you do that, you should see output like in the example.

I did not realise the I have re-enable that each time the application crashed.
Now I went three time through the cycle: crash, enable debug, restart, test, crash...

This is ridiculous. Please ad vise how I can go back to V10.

You don't have to reenable it each time, but you may need to wait 10 seconds after OK for the Preferences to be saved. So if you're triggering the crash right after making the change, it might not have been saved yet, but if you wait 10 seconds before right-clicking anything, it'll be fine.

You can also force them to be saved using File > Exit Directory Opus.

Either way, you'll probably only need to generate the debug output once.

I also had this issue with Dopus 11. In Dopus 10 it worked ok, but in Dopus 11 it crashed on right click on any file.
I've checked Windows Event Log, and there I found it was due to Notepad++ shell extension.
I've updated Notepad++ and the problem was gone.

But since it worked properly on Dopus 10, I'm guessing there maybe an issue with Dopus 11. Not sure how shell extension works but I'm guessing that Dopus shouldn't crash due to some shell extension error.

Maybe your issue is with some arhiver application, try to update the one you're using.

No, shell extensions add code to the Opus process, and if that code crashes, the whole process crashes, even if we've done absolutely nothing wrong.

That's why they can take out Explorer as well.

No, shell extensions add code to the Opus process, and if that code crashes, the whole process crashes, even if we've done absolutely nothing wrong.

That's why they can take out Explorer as well.[/quote]

I see. Thanks Leo.
Then it is strange how it worked with Dopus 10 for months, but when I switched to Dopus 11 it started to crash.

It's not that strange if the crash was due to random memory corruption or something similar. Things move around in memory and something that was harmless becomes serious.

As an example -- and I'm not picking on Notepad++, which is a good app; I just found this while looking to see if any recent changes mentioned the shell extension -- the Computer Management tool in Windows 8 was crashing until a Notepad++ update to fix something in its shell extension: ... lease.html

Anyway, talking about this here is making it harder for zumaxb to find the information he needs earlier in the thread, so let's leave it.