DO11: Right click file properties crash

Just started trying out DO11 beta (5 and 6).

In both versions right clicking a file and selecting Properties... crashes Directory Opus 11. This occurs every time I try with executable files; haven't tried other file types but I suspect it will crash on those as well.

Windows 8.1 x64

The crash is probably from a 3rd party shell extension that extends the Properties dialog.

It's worth checking what happens with the same files in Explorer, in case Opus isn't involved at all, and also worth checking with some other file types to get a better feel for what might be involved.

You can then use ShellExView to list and try disabling the shell extensions on your system. The extensions with type Property Sheet are the ones which are likely to be causing the problem if it only happens with the Properties dialog.

Any file type crashes Opus 11.

Explorer doesn't have any problems displaying the properties dialog window. There are no 3rd party shell extensions marked as Property Sheet they are all from Microsoft as standard.

Opus 10.5 also didn't have any issues, it only seems to have started since upgrading to Opus 11 beta.

Make sure the 64-bit version of ShellExView was used.

It's also possible that a shell extension from the context menu itself is causing the problem. You can quickly test if that is the case by turning off Preferences / Miscellaneous / Windows Integration / Hide Windows items on file context menus (shift overrides) in Opus.

FWIW, I see no problems here when trying the same thing:

I've now tried this on two computers (both Windows 8.1) and both crash when trying to get file properties from the right click context menu.

I did what you suggested and disabled the windows context menu items and DOpus 11 still crashes. Once restarted the hide windows items option reverts back to showing both.

I did use the 64bit build of ShellExView.

If you change the option, then use File > Exit Directory Opus, then re-open Preferences, is the Opus also changed back then?

Can you think of anything the two machines have in common that isn't part of a standard Windows install? (e.g. other software, antivirus scanner, etc.)

If a crash dump is created matching the time of the crash, that may also help track down the cause. (Please link your account if you want us to look at a crash dump.)

The setting does stay active if Opus is quit fully.

Common items between the computers:

Kaspersky Internet Security 2014
Password Depot 7.5
Auslogics BoostSpeed
O&O Defrag 17
Phrase Express

I've just tried closing all of them down and it's still crashing :frowning:

I've linked my account and attached the minidump that was generated as a result of the crash. (27.7 KB)

If you bring up the Properties dialog in Explorer does it have any non-standard tabs in it (besides those shown in Leo's screenshot)?

Now that you mention it there is one: Acronis Recovery.

Which is a part of the Acronis True Image backup application. That has been installed for well over a year and didn't have any issues with Dopus 10.x

Tried to disable it using ShellExView but the property page still remains. It's not something I want to uninstall or disable as it's used to maintain a full system backup.

The various Acronis shell extensions have caused a lot of problems over the years, including sometimes in Explorer. (I ran into one where it leaked about GB of RAM when right-clicking files, but there have been many others as well, including several crashes.)

So much so that we blacklist the Acronis extension that we can by default. (Unfortunately, we have no control over what the Properties dialog loads, as it's part of Windows rather than our own code.)

...having said that, I took a look at the crash dump and it shows the crash is happening inside of YandexDisk\YandexDiskShellExt-3998.dll

I uninstalled Acronis and it was still crashing. Then I saw you latest entry.

Is there anything I can do about the crash? I use Yandex.disk as my cloud storage, I'd really prefer not to loose it.

You should be able to disable the property sheet extension in ShellExView. It's odd if it is not showinf it.

Your other option is reporting the crash to the Yanex team. We can assist them if needed but they'd need to do the initial investigation since the crash is coming from their code, which we don't have access to, when called from the Windows Propeties dialog which is also not our code.

There are no property sheet extensions for Yandex. ShellExView is showing a Context menu, Drop Handler, Icon Handler and 4 Icon Overlay Handlers.

Try disabling the ones that are listed, then reboot to see if it makes a difference.

If it doesn't, or if you want the crash fixed, you'll need to talk to Yanex since we can only guess at what their extensions are doing and how they are related to the Properties dialog.

Sadly, disabling all the Yandex entries didn't help. So, I'll see about posting a query to Yandex.

Thanks for the help.

What Yandex said? Three month of using DO11 crashes every day. Annoying!!! Windows Explorer doesn't crashes.

They said they'd look into it, but that was months and months ago. Haven't heard back :frowning: I actually didn't upgrade to DO11 in the end. DO10 doesn't have the crashing issue with Yandex.