GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Doesn't maximize properly with (Matrox) multiple monitors


#1

Summary: Misconfigured graphics card drivers can tell the operating system that there’s one huge monitor attached when there are really several different monitors; this can cause Opus to incorrectly maximize across all screens instead of just the active one.

If you’ve got a system with multiple monitors and you find that when you maximize an Opus window is covers all of them, instead of just the monitor that it is on, then it is likely your graphics card drivers are misconfigured.

Unless you’re running a huge display at a trade show or similar, Windows should be told by your graphics card about each monitor individually. If the graphics card is lying to Windows by telling it there’s one huge display then there is no way for Windows, nor programs like Opus, to know where the monitor boundaries are.

In the case of Opus this can mean it doesn’t maximize its windows properly. In the case of Windows it means the taskbar will span all of your monitors rather than just one of them (this should never happen on Windows 2000 or XP with properly configured graphics card drivers unless you’re installed a 3rd party multi-monitor taskbar tool).

A correctly configured multi-monitor system will show multiple monitors in the Settings tab of the Display control panel applet:

The Matrox range of graphics cards is known to have an option which switches between properly informing Windows of each monitor and lying to Windows about there being just one big monitor. Unfortunately the option is very misleadingly named and, at least in some corporate environments, is on by default.

To correct the setting on a system with a Matrox graphics card, open the Display control panel applet, flick to the Settings tab, click the Advanced button, then find the DualHead tab:

Select the DualHead Multi-Display item in the list and click Change Settings… to open another dialog:

To properly report each monitor to Windows you need to select the top option: Separate resolutions and color palettes for both displays. Note that even with this selected you can still select the same resolution and colour depth for both displays.

OK all the dialogs and you’ll probably be prompted to restart Windows. After rebooting everything will be the way it’s supposed to be.


List of FAQs organised by topic
Multi-monitor DOpus