GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DOpus 10 Folder Tree redraw anomaly


#1

The circumstances for this are a bit weird, but here goes…

  1. This only happens with Drive C: in Explorer View (I think because it’s typically the first Drive listed), and it only happens if there are a sufficient number of folders on Drive C: to cause the below steps to make the Folder Tree list scroll down enough so that Drive C: has scrolled up beyond view (This also depends on the vertical size of the DOpus 10 window).
  2. Highlight drive C: in the Folder Tree.
  3. Double-click on a folder near the bottom of the list in the right pane to open it.
  4. You should notice that the list of elements of the opened Drive C: in the Folder Tree have shifted, or scrolled down sufficiently to cause Drive C: to scroll up out of view.
  5. Use the Folder Tree scroll bar to go back to the top of the Folder Tree.
  6. Click on the Expand/Retract Tree arrow next to Drive C: in the Folder Tree to retract the expanded view of Drive C: contents.
  7. Note the weird/scrambled order of the Folder Tree contents.
  8. Hovering the mouse cursor over the affected Drive listing area may straighten out things, but the sure-fire way in my configuration is to simply click once on the Explorer layout tab.

I hope someone can duplicate this. Quite bizarre, I’d say.

Scott J.


Directory Opus 10.0.0.1 to 6 (betas)
#2

Is this with 10.0.0.0 or 10.0.0.1?

The 10.0.0.1 update we released yesterday has some fixes for this kind of thing. (It’s linked in my signature.) I’m not sure if it fixes what you’re seeing but it’s worth a try as a first step (unless you’ve already tried it, of course).


#3

Um…the original release is still on your site. Just to be sure, my complete version number is 10.0.0.0.4137, and that seems to be the latest available, unless there’s a “special” place I should be looking for the update…?


#4

See viewtopic.php?f=27&t=14136


#5

Thanks for the “pointer,” Bob. The update didn’t work for the problem, though. Strange one, this is. Windows 7 x64-SP1 (forgot to include that little tidbit).
Plus, I haven’t been able to duplicate it on my work computer, which is Windows 7 original release 32bit, but that one doesn’t have the number of drives (C: through U:) listed in the Folder Tree, which may be part of it.


#6

Have a look at the attached screen shot to see what this is all about.
To restore the proper view, I just need to click anywhere in the right pane.



#7

Hi scottj.
How did you get the old style menus?


#8

Hello Protocol,

The attached file is a DOpus 10 config I worked up to get my version 9-style appearance, since I’d grown so used to it. Give it a go, if you’d like.
You can load it using Settings/Backup and Restore. I’d advise doing a Backup beforehand, just in case.

Scott J.
Administrator - Opus Config - 06-May-2011.ocb (46.6 KB)


#9

[quote=“Protocol”]Hi scottj.
How did you get the old style menus?[/quote]

If you updated over an Opus 9 install you’ve already got the old menus, they’re just turned off. See the FAQ or blog-post I added yesterday.


#10

Thanks guys.


#11

FYI, I’ve tried a clean-install of the new 10.0.0.2 beta, and the problem as seen in the above screen-shot persists.


#12

Hello,

I’ve been searching through the forum for a solution to a similar problem and I came across this thread. I think I’m experiencing the same issue. (My OS is also Win 7 64-bit SP1.) An example for my case: I’m in my “Downloads” folder and I delete a folder that is listed on the right hand pane and the Folder Tree re-draws with an additional “Downloads” folder. A snapshot of my example follows. I collapsed the first Downloads folder which does not function if I try to click/double click on a folder in the tree. Only the second one works.



#13

Addendum:

  1. Deleted or moved a folder that appears in the Folder Tree or copied a folder so that it appears on the Folder Tree
  2. Clicked on a folder in the Folder Tree, then a new Downloads folder appears

#14

Fixes for at least some of these problems will be in the next update. We’re not sure if 100% of them will be fixed as we haven’t been able to reproduce all of them, but they all seem like the same underlying problem and if so should be fixed when the new version is ready (which shouldn’t be too long now).


#15

Thanks for the update. I did notice that it’s more or less a refresh issue (at least on my end). If I hit the F5 key, the Folder Tree will correct itself. Anyway, love the program and looking forward to a possible fix. Cheers!


#16

Leo, I just tested out version 10.0.0.3 beta, and the problem persists. I have also been able to duplicate it on my work machine, which runs Win 7 32-bit.


#17

Here it is on my work machine. Duplicate Folder Tree entries can be seen for Drive Y:

This seems to be more easily duplicated when the lister window has reduced vertical height if one doesn’t have several elements in the Folder Tree Pane (Explorer View).



#18

Seems odd that the tree’s root item isn’t even visible.

Please post screenshots of Preferences / Folder Tree / Appearance and the Options page after it. I’ll try configuring my tree in the same way for a few days and see if it happens for me.


#19

Here are three screenshots. I included the Selection Events as well.







#20

I just tried version 1.0.0.0.5, and you can see that a fix has not yet arrived for this.