Dopus not updating folder (intermittent issue)

Couple days ago, I noticed that dopus wouldn't update the folder and show all files in the directory and that I had to force an update with F5. The problem went away but just came back...

Here, the comparison of file explorer and dopus with two files in the directory.

When I delete the file in explorer, the file remains in dopus

until I press F5.

Is there a way to force automatic refreshes?

I did exactly that before taking those screenshots. This resolved my icon size issue yesterday...

I just shut down dopus again and started, copied a file into the File Explorer window and dopus didn't show it :frowning: It required me to press F5 before it showed up

What does the debug output show?

I looked up how to do it... Here, I enabled context_menu_debug, downloaded DebugView and let it run. Nothing got flagged when I copied a file into explorer

Is this what you were looking for?

Either change notification is completely broken on the machine or the debugging isn't turned on.

If you see any changes update folders in Opus but nothing in the debug log, it's likely the debugging isn't turned on properly.

Do you have any step by step instructions maybe?

Only what's in the guide I linked. :slight_smile: (I can't think of any steps that are missing there, at least.)

Have you tried everything in the guide? ChangeTest.exe?

Oh, sorry. Didn't read the debug portion of the linked doc...

Went ahead and followed those instructions and logged the activity in the directory with ChangeTest. It did log something but the dopus did not update when I copied a file into file explorer

ChangeText.exe working is a good sign at least.

But Opus still won't output any change information to DebugView, when notify_debug is turned on in Preferences?

If you use File > Exit Directory Opus, then re-open the program, is there still no information when changes are made?

I can confirm that notify_debug is turned on

I exited dopus and started it again, copied a file into file explorer while logging that directory with ChangeText.exe. Once again, the file is not displayed in dopus :frowning:

So there's nothing in DebugView when notify_debug is on and you make changes, in that folder or any other folder?

ChangeTest was setup to monitor just that one folder. However, I am seeing the same behavior in other folders. I just realized though that this applies to folders only that are managed by onedrive. if I copy a file into a folder outside onedrive in explorer, the folder gets updated right away in dopus.

Not ChangeTest, DebugView.

DebugView does not seem to log anything when I copy a file into the test folder "Test-DOPUS"

A number of items are logged within DebugView but nothing with "Test-DOPUS" inside

were you able to reproduce these findings?

@Leo any chance you can get this fixed?

Can we see the log data? Difficult to diagnose things from a screenshot where all the info is cropped out. :slight_smile:

sent you a message with logs

Thanks! Looking at the log, there are no notifications for D:\ at all.

So either Opus isn't monitoring D:\ (despite showing it, which would be unusual) or something is filtering the notifications Opus receives.

I'll see if we can add some extra information to the logging to report which folders we're monitoring so we can rule that out. I'd be surprised if the issue is there, but it's possible.