GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Double-click not working for some file types

Just updated Windows. Oh boy, they don't like you folks... Directory Opus is trashed. Just installed the Patch to the Update. No joy, still trashed... Reinstalled newest Opus. No joy, still trashed... Basically, I can't double-click anything except a text file... Also, when selecting multiple files, that doesn't work either... Any help or explanations would be appreciated,

What happens when you double-click something other than a text file?

What happens if you do the same thing in Explorer?

What exactly do you mean by "selecting multiple files doesn't work"?

What happens when you double-click something other than a text file?

Directory - It opens.
Image (png, jpg, bmp, gif, mp4) - Nothing happens. Same as single-click a file then press Enter - Nothing happens.

What happens if you do the same thing in Explorer?

Those files Open as they should. Images open in an image viewer, Gifs open in a Gif viewer, Movies open in a Movie viewer... (

What exactly do you mean by "selecting multiple files doesn't work"?

Okay, here we go: If you want to select multiple files there are a couple of options: First is click a file, then hold Control key and click more files. This used to work and now doesn't. Instead, I click a file, it's highlighted, hold down Control, move mouse to next file, it's automatically selected instead of waiting to be clicked. If I click it it's unselected. I kind of like this but it's not standard.

Second, click a file, move mouse to 5 files down a list, hold down Shift, click 5th file to select all of the files in that range. This used to work and now doesn't. If you click a file, move the mouse, they are all selected if you don't click the last file. If you do click the last file that one becomes the first selected file.

Basically, moving the mouse paints the panel selecting files AS LONG AS you don't press another key. I like this but it's unexpected and non-standard.

Also, where's Help? I can't find it anywhere.

It sounds like you've turned on Preferences / File Displays / Mouse / Single click to open an item but didn't want to.

It sounds like you've turned on Preferences / File Displays / Mouse / Single click to open an item
but didn't want to.

Yes, that was on, when I was trying to fix DO. I turned it off, closed DO, opened DO, same problems...

Also, I have Thumbnail display selected. When I close then re-open DO, that selection is not remembered...

So you still can't ctrl-click things with that option now turned off?

Is it still off if you look again in Preferences, or has it come back on again?

Have you done anything unusual with your mouse or keyboard drivers or configuration recently? Or installed any tools like macro/gesture software?

Let's stick to one problem at a time, please, else we'll lose track of what we're talking about.

So you still can't ctrl-click things with that option now turned off?

Still can't double-click.

Is it still off if you look again in Preferences, or has it come back on again?

Yep, still off.

Have you done anything unusual with your mouse or keyboard drivers or configuration recently? Or installed any tools like macro/gesture software?

Haven't done anything except the Windows update, then the patch to the update.

Can you CTRL CLICK things now?

Let's get that fixed first, then worry about what happens when you double-click different file types.

Yes! Control hold, click, click, …, and I select multiple things. Shift hold, click, move mouse, click also selects multiple things. Sweet! We're halfway back to normal!

Moving on to double-clicking, is the problem only with images and movies, or all files? Do text files work?

If the viewer pane is open, try closing it.

Which image viewer are you aiming to use? The Opus one, or another one?

Text files work, they open in Notepad. Movies don't double-click. Gifs don't double-click. Images (bmp, png, jpg) don't double-click.

Gifs: Right click, select Open With, select Choose Default Program, select Gif Viewer, click Always Use This App, click OK. Then they open however that has to be done every single time.

Movies: Right click, select Open With, select Choose Default Program, select Windows Media Player, click Always Use This App, click OK. Then they open however that has to be done every single time.

(I'm going to be offline for 2 days...)

What does Preferences / File Operations / Double-click on Files look like for you?

Please also open Settings > File Types then, at the top left of that dialog, select File > Diagnostic and save the results for .gif, .png and .mp4 and attach the results.

My double-click om files had internal sound player unselected, now it matches what you had.

Opus_FTD_File_gif.zip (58.4 KB) Opus_FTD_File_mp4.zip (57.9 KB)

New users can only do 2 at a time...
Opus_FTD_File_png.zip (58.2 KB)

If you want to use an external image viewer then you should turn off Use internal picture viewer.

If I turn that off double-click doesn't work. I turned it off. Nothing shows. I turned it back on, still doesn't work.

Are you sure nothing happens at all? If you check on your Taskbar, is a viewer window opening? It could be opening off-screen for some reason.

Do you have any script add-ins installed? Those can break or divert double-click events.

I'm sure, nothing at all. I had Internal Viewer for Unregistered file types, I just changed it to registered file types. I can now view images (bmp, png, jpg).and gif files. Nothing happens when I double-click an Mp4, MOV.

I've never done anything to DO, no scripts or add-ins.

So that wasn't true before?

Have you tried turning off "use internal picture viewer" and then using Open With to assign a different viewer to the one you're having problems with? Does that work, or is it the same problem no matter which viewer is used?

Try Paint (MSPaint.exe) as a good test. Avoid "Metro" and Windows Store apps as they complicate things (although they should work, let's see if something simple works first).

Check the change applies to the Desktop as well, since Open With has been broken completely in some versions of Windows.

I think it was true but I can't swear it... (I know you want to do one problem at a time, but another problem I have is certain changes aren't remembered...)

Okay, turned off "use internal", right click a GIF, select Open With, select "choose default" select "GIF Viewer" and select "always use". That GIF opens correctly. Close it. Double-click same GIF, nothing happens. I can repeat this but the "always use" is not remembered.

A JPG. Right click a JPG, select Open With, select "choose default" select "Photo Viewer" and select "always use". That JPG opens correctly. Close it. Double-click same JPG, still works correctly and was remembered.