Double-clicking shortcuts opens new lister if QAP installed

I noticed a change in behaviour between Directory Opus 12.21 and Directory Opus 12.21.6 beta (I only tried beta 6), which persists in Directory Opus 12.22: double-clicking shortcuts opens a new lister window rather than opening the folder in the existing lister. I presume this is not intentional (I couldn't find an option for modifying this behaviour either).

If I had to hazard a guess, I'd say it has something to do with the following modification that appeared in beta 2:

Go FOLDERCONTENT now treats shortcuts to folders like folders. (Unless noparselinks is specified.)

Like so?

Works fine here, windows 10 Pro 2004

Assuming we're talking about double-clicking shortcuts to normal folders, from outside of Opus, it's working OK for me, as long as Preferences / Launching Opus / Explorer Replacement / Open external folders in a new tab is turned on.

Try changing one of the settings on that page, clicking Apply, then changing it again and clicking OK. That should re-write the related registry values if they aren't already what they should be.

No, I'm talking about double-clicking a shortcut from inside Opus. Here are a couple of screenshots.

That still opens them in the current tab for me.

Do you have anything overriding the Actions or Events for the LNK file type?

Nope, nothing set under events. That's weird. There's a clear difference in behaviour between 21 and 22.

I'll try beta 1 and beta 2 and see if the problem appears in beta 2

Actually the problem starts in 21.1

I can't see anything in the release notes that sounds related.

I don't use shortcuts, so I can't say if it changed with the update to 22. However, if I double-click a .lnk shortcut right now, it opens a new default lister. Here are some screenshots in case it helps with diagnosis.


I suspect the cause on my machine is Quick Access Popup. It's associated a new default action with .lnk files in the registry. I don't use it so I'll look at how to restore the normal default action. If I choose "Open target folder", Directory Opus opens it within the current lister as expected.

However, something has changed in how DOpus handles .lnk files in a case like this.

The way Opus opens folders changed due to a bug in Windows 10 2004. (Where things using DDE to open things causes the desktop to hang when things are double-clicked. It also affects some of the MS Office apps, so it wasn't something we were doing wrong, but we could change things to avoid the situation, so we did.) That could be the difference, although I'm not sure, and it's certainly not causing problems with any of my machines.

Maybe Quick Access Popup needs to update something on its side as well, if it's really involved. I don't know that much about it, though.

I have the latest version of QAP installed since I first installed OPUS and through all betas up until 12.22 stable. It never caused any problems. The developer also spends a considerable amount time integrating it with opus. I doubt QAP has anything to do with this.

1 Like

Do your shortcuts open in the same lister window then?

Well I very much suspect that it's QAP. I just deleted the lnkfile shell command which is the default with QAP installed:

HKEY_CLASSES_ROOT\lnkfile\shell\Import Shortcut to Quick Access Popup menu

Now the default command for shortcuts is "Open in Directory Opus", and double-clicking behaves as expected, opening within the existing lister:

Import the QAP command again, and the default command reverts to "Import Shortcut to Quick Access Popup menu", and the behaviour changes back to opening in a new lister:

Seems pretty conclusive.

1 Like

Yes, as I have shown in the video I posted before. I also have that registry file and "Import Shortcut to Quick Access Popup menu" is the first of my context list but it did not affect how opening shortcuts is handled. I am frankly still baffled that it does. Glad you managed to figure it out a fix!.

Odder and odder.

When I did my test (shown above), QAP was not running and I had the "Open Target's Folder" as the default right-click action and it still opened a new lister window. Also, I didn't realize it at the time, but I was still on DOpus 12.21.7 beta. I have since updated to 12.22 and started up QAP and it showed the same behavior. Today, I updated to the just-released QAP v11 and it behaves the same way (opening a new lister when double-clicked).

@jnllnd Is there a way to customize the right-click Context menu that QAP shows? For example, can we ask QAP to let something else be the default (bold) action? Also, for testing purposes, can we easily remove and re-add the QAP context menu entries?

@leo: Disregarding QAP and noting my filetype settings for .lnk above, what else can I do to see if I can make it so double-clicking a .lnk file will open the folder in the same lister and tab?

1 Like

@jnllnd Is there a way to customize the right-click Context menu that QAP shows? For example, can we ask QAP to let something else be the default (bold) action? Also, for testing purposes, can we easily remove and re-add the QAP context menu entries?

If you install QAP with the Easy Setup exe file, QAP creates registry entries for the context menu automatically. These can be removed in "Options, Popup menu". But you cannot select which entries to add/remove. They are managed globally.

On the other hand, looking at your screen capture, I realize that the context menu in DOpus is quite different than the same context menu in Windows Explorer. In Explorer, the default menu entry (in bold) remains "Open" ("Ouvrir" in my French env.) and it is what is desired. Why is it so different in DOpus?

I could post the registry keys created by QAP for context menus if it can help.