Empty Fantom Folder

I have a fantom folder showing at the root "F:(F:)" that I cannot get cleared. This folder is only visible in Directory Opus and does not show in Explorer.

I have the latest version of the app on Windows 10. I have disconnected all of the external drives and then restarted the computer. The empty folder is still visible and also get an error stating that the system cannot find the folder.

Any help will be appreciated.

What's the folder's name? That might be a clue about where it's coming from.

If you open a Command Prompt and run these commands, is the folder listed by either/both?

dir F:\

dir /ah F:\

Or are any other folders listed that don't correspond to ones you expect? (It's possible the folder has a different name on disk vs the localised display name, as happens with e.g. "My Documents" and "Documents" in some versions of Windows.)

I performed your recommended CMD procedure and tboth of these commands state that "The system cannot find the path specified".

I believe this problem started after I assigned a new drive letter to a drive within an external USB dock. I tried to re-assign the drive letter from a "F:" to an "R" drive. When I did that, the "F:(F:)" drive is still visible in Opus (but not showing in Explorer.

The USB dock is not the problem because If I disconnect the dock, the "F:(F:)" drive is still visible (but still not showing is Explorer). I found that if I revert the name back to the original "F: the drive display's correctly in Opus and Explorer.

I tried a freshly formatted drive and assigned it with a different letter such as "L", , the problem drive letter "F:(F:)" re-appears.

After some experimenting, I tried to rename a second external USB drive that is attached to the computer. I tried to rename this drive from "S" to drive"D". The "D" drive displayed correctly. So, I then renamed back to "S"and then back to "D". Now, I have a phantom drive "S:\ (S) listed, but not in Explorer.

To add to this problem, whenever Opus is running, the delete key will not work in any program such as Word or within Explorer. If I stop Opus, the delete key works.

I did a complete uninstall and re-install of Opus. I am using 12.22 X64 Build 7593.

Please advise.

Have you tried rebooting after you changed the drive letters?

That probably means you have either created a system-wide hotkey on that key within Opus (Settings > Customize Toolbars > Keys), or you've floated the Operations toolbar (so the toolbar itself is a separate window, not connected to a lister or file display; that will make any hotkeys in the toolbar global).

Yes, I have tried rebooting every time. I just noticed what is probably an important thing. The drives show up under "Network Locations". They are still not visible in Explorer.

If you paste shell:::{289AF617-1CC3-42A6-926C-E6A863F0E3BA} into the path fields in both Opus and File Explorer, does either program list anything there that mentions the old or new drive letter?

Similarly, if you do the same with %APPDATA%\Microsoft\Windows\Network Shortcuts do you see anything about the drive in either program?

No, the only item listed in both paths are the root of my NAS drive.

I'm quite confused about whether this is a phantom folder or drive letter or exactly what. Could you please post a screenshot to clarify?

Are you running Opus elevated ("Run as Administrator")? It'll say "ADMINISTRATOR" in the titlebar if you are. That could explain things, as the admin context can have a different set of drive letters to the standard user.

It was running in standard mode. I exited the program and ran it as administrator. The drives as visible in both modes.

Please go to %APPDATA%\Microsoft\Windows\Network Shortcuts in Opus, and post a screenshot of the whole window?

This is quite strange.

Could you record a Process Monitor log of what happens when you open This PC in Opus, and send the result to us?

Please ensure that both Registry and FileSystem events are being recorded, since the unwanted drive could be coming from either place:


I sent it this morning.

Thanks for sending the log file! But it doesn't look like the This PC folder was opened/refreshed while the logging was happening?

Each time the This PC folder is loaded, it should cause Opus to look in the Network Shortcuts folder (among other places). If I filter on those events like this:

Then I see this on my system when I open a window and go to This PC:

(If I go to it again, more similar events will appear.)

But if I filter your log in the same way, I don't see any events:

Did you open the This PC folder in Opus while the log was being made?

(The folder needs to be opened or refreshed after logging begins. If it's already open in a tab, just bringing the window or tab to the front may not cause anything to happen.)

I tried again and opened up my pc in Opus and also in Explorer. See if this captured the info;events.zip (9.3 KB)

That's the wrong type of log file. (Looks like either a summary of some kind, with counts of events per process but without any individual events, or something saved from a Task Manager type tool rather than Process Monitor.)

I am not as familiar with process monitor. I believe I captured what you want. I opened Explorer and opened Opus several times to display to phantom files. Hope this was a good capture.

Many thanks for the new log! That has the information we needed.

Please could you do one more thing so we can fully understand what's going on:

It looks like there are mapped network drives under the old letters, but we need to work out why Opus is showing them and Explorer isn't. Once we know that, we should be able to filter them out in the same way.