Exception number: 80000007 every time

Everytime I use Directory Opus I get Dr Watson dumping error log and .dmp files. The error log always says -

Application exception occurred:
App: E:\utils\Directory Opus\dopus.exe (pid=1588)
When: 12/23/2006 @ 15:03:04.921
Exception number: 80000007

I reinstalled DOPus and now get Runtime error 217 at 0332F452 when it closes.

Try the steps in this FAQ:

[Crash, exit or high CPU when viewing certain directories)

It could be a file in the directory that Opus is set to show when it starts. Making it show a different directory may let you load it without the crash and then you can experiment to work out which file(s) are causing the problem and work from there to solve it.

"Runtime error 217" isn't an Opus error. It could be the Source Code Viewer plugin, or another plugin or context menu extension.

Did you ever get to the bottom of the error 217? I see that error also, and have found that its related to Delphi - but that doesn't tell me a thing...


Try disabling all of your viewer plugins. If you can't get Opus to run to get into the Prefs dialog then you can just rename the Viewers directory to something else.

It could also be a shell extension or something else. The steps in the FAQ linked above cover ways to track that down. Most important thing is to get a lister opening with an empty directory. If you can do that then you know it's probably a file (or rather, the thing which handles the file) in the other directory which is triggering the problem.

Running Process Monitor while Opus starts can also help track things down. Often the one of the last DLLs which a process loads before a crash is the culprit. This can also help for working out why Explorer is crashing (e.g. this thread).

It's related to some shell extension or similar you have installed what is being called under the instance of Opus.

You'll need to analyse what you have installed. As another test, you may find this utility useful in identifying the actual cause of the problem.


Others have reported the 217 error was caused by...

. Java RTE5 update 9 may have caused the problem. DOpus works great after Java was updated to RTE5 update 10.

. PowerISO and it offers shell integration. I disabled it and this issue is solved.

.The problem was related to KB908531. I renamed verclsid.exe and the problem went away.

.I found the problem and it ISN'T YOURS :slight_smile: Its that pesky alcohol 120

I think I resolved my problem. I had installed audioshell (softpointer.com/AudioShell.htm) recently. After I removed it, dopus behaves properly, no more error 217! Once I resolve some other (hardware) issues I will reinstall it and verify the connection - right now I need to keep my system running and don't want to rock the boat since my backup program is misbehaving and won't back up any more... but that's a different story :wink:

Nice one Scubaman. I have had audioshell installed for years and would never thought it could be causing a problem. After reading your post I uninstalled it and DOpus runs OK now.

Give it a try in Opus 9 once it's out (assuming you upgrade). If it still doesn't work then we should try to work out what the conflict is.