F-Secure manual scan option gone since SAFE version 8.1

< right mouse button menu >
With afaik all versions of DOpus, up till current version 12.25, using the right side mouse (file properties) menu, I was able to select to scan with F-Secure, my AV of choice, a single file, several files, a directory or a group of directories. The right side mouse (properties) menu is still there. Yet, since F-Secure SAFE update from 8.0 to 8.1, a few days ago, the entries enbling scanning a given (file, directory) selection are gone... The Microsoft (File) Explorer though seems not affeced, does still offer this to me convenient offer. I would love the return of the presence of ' scan the given selection '.
At the moment the issue I asked the F-Secure people and they are investigating the issue.
They already confirmed the issue was reproducable at their site.
Can we expect something from Directory Opus too ?
I was and still am running Windows 10 and Windows 7 (same issue, same details even) at my machines.

If it's caused by an F-Secure update then it's presumably something they changed recently.

It sounds like they are looking into it already so we'll see what they say. If it's not intentional and a compatibility issue triggered by a change on their side but where things should still work, then we'd be happy to make changes on our side if they're needed (within reason, of course).

Some antivirus vendors (e.g. Norton) intentionally disable their menu items outside of File Explorer, although I don't know if this change is intentional on F-Secure's part. If their virus scanner has a command line interface then it's usually easy to configure a replacement menu item within Opus that does the same thing.

Hi, I have the same problem. F-Secure manual scan can be done by Windows Explorer, but not by Opus anymore since v. 12.25. Updated Opus till 12.26 and F-secure to the latest also. I can't change settings for this in F-Secure. Because manual scanning (richtclick) can be done by Windows Explorer I asume this is a bug in Opus. Hope you will find a solution. Regards, Michiel.

See the posts above. As far as we are aware, it's not an issue on our side. Have you contacted F-Secure about it? The first post said they were investigating it, at least.

Thank you Leo for your quick reply. I have contacted my provider for this. I have followed theit advise first, removing and reïnstalling F-Secure fully. I could remove and reïnstall Opus as a next step? I will seek contact wit F-Secure directly. Thank you so far. Regards, Michiel

I've had a look at this in more detail this morning and F-Secure SAFE is now using a type of context menu handler we didn't support (and which is undocumented, as far as we can tell), but which we've found a way to get working. So it should work in the next beta/update.

1 Like

Hi Leo, thank you for this effort. I will wait for the next update of Opus. I asume this will be announced within the program as normal? With regards, Michiel Firet.

It'll be as normal. Turn on checking for beta updates (or keep an eye on the forum) if you want to try it sooner in 12.26.1 without waiting for 12.27.

1 Like

Good to read. Sigh. After having mailed to F-Secure Customer Care some 11 times during actually weeks, complete with several asked for screenshots for both my Windows 10 as my Windows 7 (spare) computer config, things (to me) vanished in the hay, wondering if things were/are picked up in effect, in the end... Or not (grins) . No clear outcome to me so far from F-Secure. Cool you can fix things on your own guys !

Fixed ? F-Secure SAFE context menu not appearing. The 1st beta does not change a thing in my Windows 10 configuration. Tried: single file, group of files, single directory, group of directories.

Does it appear if you hold shift while right clicking?

Tried: without holding any Shift key, tried holding the left Shift key, tried holding the right Shift key.
All to no avail. Windows 10. Detail:
The right click menu has 22 instead of 15 entries when holding a Shift key pressed while right clicking, yet no option of F-Secure or any ' anti-virus scan ' entry visible.

It's working here with the current F-Secure SAFE installer just downloaded from their website:

2022-01-21 22-28-44 Clipboard Image

Do you see the menus in any software other than File Explorer? Some tools have options to only show their menus in Explorer.

Does Help > About in Opus show it's running 12.26.1?

Versie 12.26.1 (Beta) x64
Versie 8055, 20-1-2022 14:12:08
F-Secure SAFE - F-Secure Corporation Installed at: 7-12-2021 Size: .. Versie: 18.2

Why introducing a non-specified genre of ' tools ' ? What tools ? So far only 3 aps are involved, afaik:
1: Directory Opus, recently missing entries; 2: F-Secure, 3: Microsoft File Explorer, which still offers in the properties menu the opportunity to scan selected files / directories. I am unsure what you mean by ' tools ' and I am guessing about any reason introducing a fourth (4th) software.

"Other tools" as in any literally other software that displays a context menu. The File > Open dialog in Notepad is often a good test.

Some software literally has an option (and some is even hardcoded, but that's not the case here) to exclude its menus from anything other than explorer.exe, which is why it's worth checking in more than just File Explorer and Opus.

Just tried the ap / the program (not: " Tool " imho) Notepad. The menu does show indeed, like Microsoft File Explorer, the regular entry to scan (with anti-virus) a given selection (both Files and Directories) for viruses. Generic mentioning, not explicit "F-Secure", just: Scan for viruses.

So the same as in my screenshots? In that case I don't know why it would not show in Opus with the new beta, unless it's some difference between a fresh install of F-Secure SAFE and an update over an existing install. (Or things we already covered by testing with the Shift key, etc.)

It's a standard term, going back decades. But let's not get sidetracked by silly arguments about which word to use to describe a piece of software.

Yup, agree (standard term apparently). I could try an uninstall, then re-install of F-Secure, right ?

Worth a try.

Before un-install F-Secure, running CCleaner Registry & reboot the all-time fully up-to-date Windows 10 by chance I tried some shortcuts residing at my desktop. Funny enough, this is so far the only genre I found which actually did not lose it's menu entry of "Scanning for viruses".
After downloading a fresh ' exe ' from My F-Secure service, a swift and error free new install of F-Secure SAFE, version 18.2.
Guess what ? Same results as before: all entries absent, except for shortcuts.