Failing to open

I am impressed by DOpus but need to sort out a problem before purchasing.
I can not get a lister to open? when i try to open one the icon appears in the notification area for a second then disappears? It seems to have started since installing norton internet security? :confused:

And have you tried disabling all NIS features temporarily to see what happens?

NIS may be killing the Opus process because it's trying to check for a new version via the web. You can turn off the automatic update checks (Preferences, Misc. I think) but I guess you'll have to disable NIS temporarily to do so.

Then again, if NIS is that silly and doesn't even present a dialog asking if you want to allow the operation or block the net access rather than kill the process, or whatever -- I'd probably disable NIS for good. :slight_smile:

Of course, it might not be NIS but it seems a likely culprit from the info you've provided.

i got exact same problem. program opens for a sec and then shuts down. except that i dont have NIS installed. Its not for sure but it started happening after i installed windows blinds. fyi, i got mcaffee virusscan and firewall and microsoft antispyware running. but i tried it with them off... no luck. nothing could possibly be blocking it. :astonished:

Do you know if Opus is trying to open a lister window when started, or is it just trying to load into the background (i.e. just the tray icon)?

If a lister window is appearing when it starts and then exits, the problem may be a crash related to one of the files in the directory that Opus is trying to show, most likely in combination with one of the plugins (e.g. the movie plugin can go wrong in combination with a bad video codec and/or video file, and my own gif plugin also crashes with certain (very large) gif images at the moment).

Either way, it might be worth using FileMon to see which files Opus is accessing just before it exits.

Also, I assume that you're using valid Opus certificates? I'm not sure what happens once the trial certificate runs out Opus but this may be a symptom. (Although I'd expect it to pop up the licence manager dialog first.)

i got 3 more days of my trial. no im not trying to open a lister, just trying to load it to the tray.

A poster on the Yahoo group was having similar problems and found that disabling Zone Alarm for long enough to turn off Opus's Update Check functionality solved the problem.

If you're unable to get into Opus's Preferences dialog to turn off the auto-update then you can, at your own risk, also do it via the regsitry.

Go to

HKEY_CURRENT_USER\Software\GPSoftware\Directory Opus\Config\User

and find the DWORD called MiscFlags. It should be an odd number. (If it is even then auto-update is not on.) Make a note of what it is (in case this causes problems!) and then subtract one from it. That should turn off the auto-update, if I've got it right.

In case anyone is worried, Opus does not "call home" in any nefarious way. If Opus connects to the Internet it is either to check that you have the latest version or because it's been told to connect to an FTP site. You can turn the update check off in Preferences, Miscellaneous, Miscellaneous (or use the registry stuff above).

I've sent a suggestion to GPSoft that they ask during the installation whether or not you want to enable the auto update feature so that people firewalls which cause this kind of problem can avoid the problem.

If you ask me these kinds of firewalls, which do more than simply block access to the internet, cause far more problems than they've ever avoided. But nobody asked me so I'll shut up. :slight_smile: Hope the registry stuff above is helpful, either way.

Another guy on the Yahoo list has started having this problem and he suspects it is due to the latest Stardock Central (like WindowBlinds) since Opus stopped working after he installed it.

Here's some info from the Yahoo thread posted by Rik, who has sent an email to Stardock to see if they can help with the problem:

[quote]I just updated Stardock Central today - sound familiar
? - and yep !!
DoPUS doesn't startup anymore , can't start it up
manually either . I know for a FACT this is due to
Stardock . I guess they altered something yet again
which causes Dopus to crash.[/quote]

Also some stuff from me that may or may not help, if you're desperate to try things:

[quote]Oh :frowning: Maybe I was too quick to blame ZoneAlarm.

Does Stardock Central have a list of applications that it should leave alone, that you can add Opus to? (WindowBlinds had a list like that, I think.)

If you want to try changing Opus's "WindowBlinds Compatibility" flag to see if it helps you can do so via the MiscFlags registry DWORD that I mentioned previously. Unfortunately, this time it's a bit more complex and you'll have to understand binary<->decimal number conversion. But if you are game, these are the bits that correspond to the flag in Preferences:

00xxxxxxxx "WB Compatibility auto-detect"
10xxxxxxxx "WB Compatibility off"
01xxxxxxxx "WB Compatibility on"

For example, along with the other settings that are stored in the same registry DWORD, my values are (all hexadecimal):

Auto: 250
Off: 650
On: 350

(You could just use those numbers if you want. It will only change a few other flags in the same dialog I guess. If you make a note of your original number then you can go back to it after trying the three flags.)[/quote]

Rik's going to try uninstalling SDC to see if the problem goes away. I'll keep this thread updated (unless someone else does while I'm asleep/at work, hehe).

Latest from the Yahoo thread is it may not be Stardock (at least one person is using it fine along side Opus).

Running an anti-spyware scanner may be a good precaution if you're having this issue (and if not as well, of course) since one of the people who is being affected by this has found some on his system. Don't yet know if it is the cause or not.

Rik also added that it may be due to uninstalling a firewall or anti-virus product and the uninstall going wrong and disabling part of COM, which Opus uses heavily. A possible solution is here: ... /0003.html

I'm starting to wish I hadn't replied to this thread until everything was known. :slight_smile: But I thought I should post this to avoid Stardock (or ZoneAlarm) getting the blame when it doesn't look like it is them after all.

I have simelar problems with the trial version (8.x.x.x)

my lic expire in 6 days (so i want to solve problem before buy)

from one day to the next
my dir opus didn't start.
no lister - no try icon.
by manually starting dopus or try to open a folder - dopus processs start - 1 sec later it ends
(watched by Process exprorer)

I've installd Norton Antivirus (NAV) and Acrobat reader 7 since weeks without problems
there are no Stardock products

when try to watch process by Filemon or tcpmon (wininternals) both crash (exit) when i try to run dopus
anti debug script in dopus??

there is no "MiscFlags" reg entry (in the whole reg)

dopus trial ( run without problem on my second PC

after complete uninstall - reinstall i can start dopus one time, run the welcome- wizard, but after reboot or exit-restart dopus, there is the same problem:
dopus.exe starts - 0.5..1 sec later it ends


Win 2000 SP4, AMD 2000+ some ram, latest windowsupdate-updates,

Seems I'm not the only one not able to launch DOpus now. It never shows up in the SysTray, and double clicking on the shortcut (or the .exe file itself) gives a busy pointer for a second and then nothing!

This is really bad for me since I use DOpus all the time..

Checked the following installed software:
ZA Security Suite (unloading it doesn't help)
Stardock Central (neither does this)
Microsoft Antispyware (just got a new version and this might be the culprit since DOpus stopped working after installing it and rebooting the machine).

I might try removing MS AntiSpyware entirely to see if this fixes it.

Anyone else had this happening after installing it?


I'm sorry but this is simply NOT an Opus problem. On a normal system Opus works fine, no problems with Microsoft AntiSpyware, AntiVirus etc. It behaves quite normally and starts as expected.

I believe the problem may be related somehow to OpenDoc or StartDoc, windowblinds etc. Uninstall these and or contact the developers to tell them they have copmpromised the normal functioning of the OS (again).

Perhaps try the Opus Window Blinds compatability options discussed elsewhere.

If this is not the issue then do make sure that you have installed Opus from the official installed which is digitally signed by GPSoftware.

We have seen pirated versions which have spyware inclued with them and can cause such probelms. If you have installed one these illegal products then you have seriously compromised the integity of your OS.

I believe the problem may be related somehow to OpenDoc or StartDoc, windowblinds etc. Uninstall these and or contact the developers to tell them they have copmpromised the normal functioning of the OS (again).[/quote]

I have confirmed that it is indeed one of the Stardock applications that cause this mishap. I'll contact them and let them know about this.

I wouldn't do this and I bought DOpus since you first released version 6.0. But I understand what you're saying Greg :slight_smile:

And thanks for responding. I wrote this here since I believed it was the best place to see if other DOpus users had the same problems, not implying it was DOpus that were at fault.

Did anyone ever find out the issue here? I'm having the same problem, and it was only after rebooting my machine after a long time that it happened. Even uninstalling and re-installing does not help. :frowning:

Well, Opus hasn't changed so what else have you changed, updates or installed on your system?

Hi folks.

I finally got DOpus to start again (among other things that didn't want to work properly).

Having Object Desktop from Stardock, I had several programs installed to customize my system. In the past these have never given me any trouble but this time they seemed to be the reason for some instability.

After having uninstalled every program except Stardock Central and their Component Tray I still had no success in getting DOpus working.

So I thought that there had to be some startup items left somewhere. I then downloaded HiJack This and booted Windows XP in safe mode.

Upon starting HiJack This and running a scan I saw some items that had been left behind (some DLL's and IconPackager among the listed items).

PLEASE be very careful not to remove any other items that the ones referring to specific Stardock applications. There was a specific item that loaded 2 DLL's (I think one was called wbsys.dll) that I recognised as being something that the Stardock applications had installed as well.

I marked these for fixing and rebooted my system.

And lo and behold, now everything works.

If you have any questions in regard to this procedure, don't hesitate to write back to me.

I hope someone finds this useful.

hello again,

I haven't ever intalled windows blinds
but i had one stardock app installed bootskin (nonsense programm by the way)

i couldn't find any wbsys.dll or simelar...

at all - same effekt
dopus.exe run für about one second and exit without any comment...

at the latest version ob dopus from the download site

i am sure, that this is coused by an other application, but which one??

Well, seems I was wrong. Here's the contents of an email RIk Wessels wrote in the Directory Opus for Beginners Users group:

Hi folks,

I got a reply from Stardock - don't know if DOPUS-devlopers have heard
anything from them - but it was only to ask for my full system specs .

However : I have been doing some further research ( my system is
windows XP-SP 2) and it seems there has ben some issues - completely
unrelated to either Stardock or Dopus with Service Pack 2 and COM-
services "quitting on you " .

Without becoming to technical : it has to do with the Windows
repository directory and part of that directory becoming damaged .

For those of you experiencing trouble with Dopus starting up I can
assure you : it isn't Dopus and it isn't Stardock . More than likely
something more serious involving the services of Windows XP is going
on .

Some symptoms of this are :

  • task scheduler isn't working properly, or not at all

  • Windows - upon startup- is unable to register tray-icons ( including
    the one Dopus uses , preventing it from starting up )

  • upon trying to view log-events , windows returns an error saying
    "interface unknown " even though the logfiles are in fact being made
    and are present on hard disk drive .

  • you are unable to startup COM + Service , it issues an error with
    number 1067

( you can try this in the following way :

  • click start
  • in start menu , right click my computer and choose manage
  • in the left hand pane unfold services and applications and double-
    click services
  • in the right hand window scroll down to COM + and check if this has
    started and is set to automatic
  • if it hasn't started , try starting it manually
  • if you get the error mentioned above ( error 1067 ) the service is
    unable to start.

Now for the solution :slight_smile:

Apparently this isn't an easy fix .It's nigh on impossible to install
services . I suggest anyone experiencing this do do the following :

  • if you have a restore point from before the problems started
    occuring , go back to those settings , remember to backup vital data
    prior in doing so !
  • if you don't have a restore point :
  • backup ALL essential data
  • "re-install "windows XP using the option "in place upgrade " or
    "dynamic update ", normally all your settings will remain intact and
    windows will replace damaged and/or corrupted files only - but note
    the "normally " !!
    see this article :

and read the related articles as well !!

Rik Wessels

P.S. : there are ways in which one can rebuild the damaged files
manually but that is highly technical and I doubt I'm going to bother

I just hope I copied my dopus-registration somewhere :slight_smile: [/quote]

I hope he doesn't mind me quoting it here. :slight_smile:

I have no "error 1067" problems at my win 2000 SP4 problem.

Beside the main Problem, there are 3 things, i don't not why...

*) sysinternals Filemon and Regmon were killed when i Try to start Dopus

*) First time i reinstall Dopus it will run
(at the first time there will come the wizard für setting up Dopus)
and then i can use it untill i restart it (Dopus)

*) Problem appeard from one day to the other .... .???

It might be worth a try to toggle Explorer Replacement (Preferences, Miscellaneous) and Run at Startup (Preferences, Startup) off and then back on again.

Turn both off and OK the Preferences dialog, then re-open it and turn them back on again. That resets the appropriate settings in the registry.

I can run FileMon and RegMon along side Opus fine. I have seen FileMon crash once or twice unrelated to Opus but it seems quite rare to me.

If both consistently crash when a program is run I would be worried about spyware that is causing this crash on purpose in an attempt to stop people using either tool to work out what is wrong with their systems. Remember that Opus hooks into several other programs (Explorer, Messenger, etc.) so if there is a spyware infection it may not be related to Opus directly.