Filename truncation after editing in List View

Here are the contents of a Lister in List View (the first two are folders and the third is a shortcut, though this is probably irrelevant):

I paste in another file (which happens to be a another folder shortcut) named PROGRAMMING:

I then open the filename editor (F2) and add 'all types' to PROGRAMMING, thus lengthening the filename:

Instead, what happens is that the filename becomes unnecessarily truncated, as there is plenty of width in the pane.

Refreshing the pane by clicking Back and Forward, etc. seems the only way the truncation:

Narrowing or widening the pane divider does not help.

This is a minor annoyance. Is there any way round this? Thanks.

Make sure you are using the latest version of Opus ( and that the Auto-size columns option is turned on for the folder format.

(Via the Folder Options window, Display tab; or via the Folder Formats section in Preferences. See the Folder Format FAQs near the top of the list for more info if you have problems applying the change to all folders.)

Thanks again leo. As it turned out, the Auto-size columns option had been checked (this must be the default setting, since I hadn't touched it). However, upgrading from to seems to have cured the problem.

I notice Thraug's thread New filename, visually truncated ([url]New filename, visually truncated]) is a very similar problem, also you have posted an excellent tutorial about folder options here:
[url]Folder Formats: Quick Guide]