Flat view "Mixed (No Folders)" and Hidden folders


I have a directory with hidden folders (in this instance, ".git" with the "hidden" attribute set).

When I view the folder normally, it is hidden (with "1 hidden" showing in the status bar)

When I select Mixed (No Folders), all files, including those within the hidden ".git" folder are displayed.

I added ".git" to the global filter configuration (Folders->Global Filters->Folder:) with
the Enable global wildcard filters option enabled

I have "Hide hidden files" enabled.

I have "Hide protected operating system files" enabled. (I even tried protecting it with attrib /d +s .git to see if that made any difference.)

I have even enabled Miscellaneous>Advanced>flatview_folder_filters, but I am still unable to hide the contents of the .git folder.

Is there another option I am missing?


Filtering out files based on the folders they are in is not supported in Flat View > Mixed (No Folders) mode, because all the folders are always filtered out (by definition). If it was enabled in that mode, you wouldn't see any files or folders at all (at least as things are implemented currently).

More discussion here: Global hide filter not working in flat view (mixed, no folders)

The other Flat View modes can be used instead, or you can use Tools > Find Files to get a flat list of everything below a folder while excluding certain sub-folders.