Flat View without files (2)

Thanks, this works perfectly!

Hi all,

I would love to use this button. Unfortunately, the linked instructions seem to go over my head. It is also not clear to me which exact part of those instructions should be followed here.

I already tried the script code with both variants "JScript" and "VBScript", but the button doesn't seem work either way. Instead, "Script Error" is displayed in the status bar when clicking the button.

Thanks for any assistance!

I accidentally linked to the wrong post in the thread (due to the forum always jumping to the end of threads you've already visited).

The instructions you want are the Raw Commands section of the first post in that thread: How to use buttons and scripts from this forum

(I've corrected the link in the post above.)

1 Like

Thanks very much for the fast action.

Creation of that button worked well now.

Strangely however, the button leads to a different result in my left Lister as compared to the right Lister -- in the same folder.

Clicking the button in the left Lister shows all files and folders in a flat view. Doing so in the right Lister shows only the files and not the folders.

I don't understand why this is the case.

In addition, I would like to see only the folders listed (flat), not the files, when the button is used.

Thankful for any ideas!

There must be something different about how you have the right side set up. e.g. Filters already in place when you run the button.

Try closing the right tab and opening a fresh one.

This button command doesn't work in Dopus 12.28.2 Beta, it still shows all files in a flat view. Any updates to this button command?

If you mean this button, it still works for me in 12.28.2:

It is weird, this button command doesn't work for me.


Are you starting from (a different) Flat View mode when you click the button?

Or do you have any filename filters applied already?

What kind of folder are you trying it in?

I didn't start from a different Flat View mode and I didn't apply any filter before pressing the button.
I just tried in this folder for testing.


Is "Show Everything" mode on?

(Would be better if we could see the status bar, as that usually says if it's on, or any other filtering, unless the info was removed from it.)

"Show Everything" mode off.

Before click the button...

After click the button...

See if Preferences / Folders / Folder Formats / Folder Type Formats / Flat View is turned on; if it is, try turning it off and see if it makes a difference.

1 Like

After Flat View turned off, the command button works as it should.

I think I found the problem, if I turn on "Hide Filter" the command button doesn't work properly, but if I turn off "Hide Filter" the command button works as it should.

That'll mean the filename filter is overridden after flat view turns on. You could reorder the last two lines of the command to set the filter after turning on flat-view, but it'll be a bit slower that way. If you aren't using the filters in the folder format then turning off that page is the best option.

Those Hide Filters and Show Folders pages in the Flat View folder format should be off by default, or at least are off in my own configuration. No reason to turn them on unless you want that format to always set/reset the filters when turning on Flat View.

1 Like

Thank you very much for this explanation, really helped me. :+1:

1 Like

Have set up this button as an extra menu item in my flat view menu,

but I cannot get the menu icon to change

Is this possible ?

Not sure what you're trying to do. When do you want the "cloudmenu" icon to appear?

cloudmenu is just temporary icon, atm the menu button will show the grouped icon when Folders Only is selected
here is the flat view menu button atm
Flat View.dcf (2.6 KB)

Hmmm. Also there is an error with the button, using it and then turning it off, the files will stay hidden, using it again resolves the problem.