Folder Options / Filters don't get remembered


When I'm a C:\ , I do "Folder Options" , "Filters".

I add to "Hide Filters" , "File Name:" the following :


I click Apply, and the files indeed hide, I then click "Save", "For this folder".

I don't see any confirmation that the options got saved, but perhaps that's normal.

.... but the next time I run DO, the files are shown there again, and going to the filters page, it's empty again, so all my changes get lost, then DO NOT get saved ?!? :confused:

Just an update :

It seems after doing it for the 5th time or so, the filters have been saved.
Exiting DO, and restarting the filters are applied.

Seems like some inconsistency in the save method of the folders options.

Read the Folder Formats FAQ.

OK jon,

I read the Folder Mormats FAQ but the info there is outdated, there's no sign of the "Save for this folder" and other options, so I didn't have much help from it, but things are ok now.

Topic = SOLVED.

You linked the filter boxes FAQ not the folder formats FAQ.

AFAIK there's nothing outdated in the folder formats FAQ. It shows the "Save for this folder" option in one of its screenshots.

--> Folder Formats FAQ

Yes, sorry, I realized I linked the wrong page just after I pushed the submit button. I done everything as said there, but sometimes settings are not saved.

Anyway, they finally are being remembered now, thanks for the help. :wink:

I'm sorry to bump this thread up again, but the problem is there once again.

All the file filters I set about a week ago, a gone once again.

Please, what could be wrong, the filter options are only being remembered for some days, and then their gone again. :confused:

I think I have refined the cause of the problem.

Whenever I made filter changes for a folder, and saved them, exiting DO completely and re-opening it using "C:\Program Files\GPSoftware\Directory Opus\dopus.exe" /autolister, filters are being remembered properly. CORRECT.

BUT whenever I close DO completely, and double click the desktop for it to open, all filter changes are lost again. :frowning:

So, it has to be something with the doubleclick on the desktop that doesn't remember settings.

What have you got desktop double-click set to Open in Preferences -> Launching Opus?

It's probably been set to open a layout which was saved without those filters.

Hi Leo,

Thank you for your quick help !

Under "Launching Opus/From the Desktop" I have :
Bring the last active lister to the front (New default lister if no listers open)

I see that "Launching Opus/From the Taskbar Icon" is set to :
Open the default lister

"Launhcing Opus/Startup" is set to :
Open the listers that were open when the program was last closed.[/u]

Also, when I have set the file filters for the xxxxx'th time now, and saved them. I close DO using the X in the topright corner. I doubleclick the taskbar icon, and floop my filters are gone once again....

Your Default Lister probably doesn't have the filters saved. Saving filters for a folder works when you browse to that folder but they aren't used when a saved layout (or the default lister) opens - in that case, the format comes from the lister itself. So you need to make the same changes in your Default Lister and re-save it.

Hi jon,

Can you tell me how I can get my default lister on screen then ? Since I wonder where all those different settings and filters I made have gone, they are probably somewhere hidden in the configuration settings and taking up resources and space.

The weird thing is, I did set up Folder filters and I never had problems with these.

Please how can I get the default lister in my view ?


As per your settings described above, the Default Lister is what you get when you double-click the desktop or the taskbar icon. So double-click the desktop, make the desired changes in the Lister that opens, then select Settings / Set As Default Lister to update it.

Great !

That did it !

Thanks a bunch, problem is [SOLVED] finally. :slight_smile:

Just out of interest Devilder, if you go to Settings / Preferences / Listers / Options, is the option "Ignore folder format of Default Lister" turned on or off?

It's UNchecked jon.

About the option directly underneath it, "Update default lister automatically when closing a lister", I probably fixed this same problem by CHECKING this option, now it remembers my filters correctly, but I can't find a proper instruction about what that option specifically does ?

"Update default lister automatically when closing a lister" means that whenever you close a window it is saved as the default lister, as if you had manually used Set As Default Lister before closing the window.

If you turn on "Ignore folder format of Default Lister" then you won't have to worry about the folder format stored in the default lister as it will no longer be used. I think it's on by default for new installs but it may not get turned on by default for people who upgraded from previous versions. It makes sense to turn it on in almost all cases, either way.

Thanks a lot for the great help Leo and Jon ! :smiley: