Font choices for Code Editors and Rename Macro Builder

There are a bunch of fonts on my system that I know to be monospaced which I'd like to be able to set for both Display > Colors and Fonts > Fonts > Code editors & Rename macro builder, however the font list is limited to a subset of monospaced fonts, and I cannot set the desired unlisted font.

Perhaps an advanced option could be introduced to toggle this limitation so that those who wish to access their other monospaced fonts (or those rare few who wish to use variable width fonts) can do so?


System information:

- Directory Opus v12.23.1 Beta x64 Build 7710
- Microsoft Windows 10 v20H2 OS Build 19042.804

Variable width fonts won't work properly in the editor control. Allowing people to choose them, even as an advanced option, would just be giving people a way to break things.

Are you sure the fonts that aren't listed are really monospaced? They need to flag themselves as such, which is all the filtering does, as far as I can tell.

If you give us some example fonts to look at we can tell you why they aren't being included in the list.

(Aside: Please use shorter thread titles where possible, as long ones make the topic list harder to read.)

I thought it may be down to something like a flag not being set. I don't know why these fonts aren't flagging themselves as such. The one I like to use is not listed, on closer inspection, only 1 out of maybe 5 fonts that I've downloaded from that repo are actually listed. I've not noticed a Nerd Fonts font formatting poorly in other coding software, so I'm confident they are actually monospaced, it must just be the flagging issue.

There seems to be a closed issue claiming it should be fixed for cmd and powershell, which could be related to why they cannot be seen in Opus. I will re-download my desired font and test again.

The preview image on the github page certainly doesn't make it look like they would be monospaced, at least not with the extra glyphs that they've added.

There were several complications but I've gotten it working now. No fault of Opus' I believe.

It was partly user-error on my behalf as only some of the Nerd Fonts that I had downloaded (through scoop) were the -Mono suffixed variant (which is the variant that presumably has the true monospaced flag), however downloading the correct variant wasn't enough alone due to having previously installed NF fonts of the same name currently on the system.

It appears to be important the order in which the fonts get installed: If the system has a font of the same name currently installed (in my case, some NF "monospaced" fonts without mono in their names), installing a variant with mono in its name didn't change Opus being unable to see the font in its Code Editors font list. I think this has something to do with both fonts sharing the exact same family name (1 family name, 2x Regular, Italic, etc listed when viewed via Windows 10's Font settings) and the flag, for whatever reason, can't be seen or doesn't get set.

I figured it'd be simpler to uninstall all NF fonts and then only install the mono named versions. If it's important to have the non-mono variants installed on the system as well, they can be installed afterwards, as Opus will still be able to see the true monospaced fonts in its limited monospace font lists.

With each install/removal, I made sure to reboot as to see the effect on Opus. All in all, just install the mono variant, or make sure to install it first before the other variant of the same name. How this may affect other software that may be able to use the non-mono variants, I don't know (I don't actually know the benefits of each).

Thank you for your help.

1 Like

The Nerd Fonts (NF) fonts were updated to 2.2.1 and installed onto my system, but since then, Opus has not been able to see these once-able-to-be-seen fonts in its monospaced fonts lists, e.g. the Code editor fonts list. The solution before was to uninstall the fonts, reboot, install the mono suffixed NF fonts specifically, reboot, and then Opus would see them, but now, no matter how cleanly I try to install them, the fonts won't show up in the monospaced font lists where I want to use these monospaced fonts.

Maybe a bug was introduced into the NF fonts that has removed their monospace flag, or has Directory Opus changed in some way? In any case, the NF fonts work fine for the font lists which allow any font to be selected, such as for the File display font.

Interestingly, Opus still uses the NF font for some of its fonts even though it's not displayed in the monospaced font lists. So Opus can read and use the font it was once set to, but if you change it to something else, there is no apparent way to set the NF font back. I was hoping that I could circumvent the limited choice of fonts detected as monospaced by typing the name into the top of the fonts list, but that doesn't work either.

Would it be possible to introduce a checkbox to the monospaced font lists which opens up the choice of picking from any detected fonts on the system, instead forcing a strict limitation of properly flagged monospaced fonts?

I have reported the issue to the maintainers of Nerd Fonts and will report back if they find a problem with the fonts being flagged as actually monospaced.


- Directory Opus Pro 12.29.0 Build 8272 x64
- Windows 11 Pro v21H2 Build 22000.918

I can’t think of anything that changed on our side here, and it’d probably filter out all the other fonts if it was our side doing it.

My guess is something changed in the font update.

Which font in particular are you trying to use? I downloaded one at random (SpaceMono Nerd Font) and it shows up OK in Opus.

The problem is with the fonts from what I have understood, not Opus itself. All the NF fonts I've installed do not show up (which I do via a Scoop bucket), however one suggested by a developer did (CascadiaCode). You can try installing Mononoki (the .*Mono Windows Compatible.* TTFs). They shouldn't work at this time. Here's the GitHub issue.

1 Like

The issue has been fixed in Nerd Fonts release 2.2.2.

1 Like