Frequent Lockups, empty tabs (iCloud related?)

I am hoping someone can give me some direction here. I have been using Dopus for a number of years now and mostly have had no problems. I am running Windows 7 Home and Dopus 10. I am now getting frequent lockups when I open Dopus with the folder tree showing contents but noting in the file tab window. I have to go to task manager to end the process and actually reboot to restore my normal window. This is getting quite frustrating as I am afraid now to open Dopus when I have a number of other programs open (Word, Excel etc.) as a reboot is required. I have uninstalled and reinstalled a number of times with the same results. I have also done a complete scan with no Trojans or viruses found. I am hoping someone here can help explain what may be causing this anomaly as I really want to continue to use Dopus however if it continues to be unreliable I will have no choice but to look elsewhere.
TIA Dave.

Perhaps a good starting point would be, to check, if these FAQs could be of help, since the
problem most likely is triggered by third party programs, personal firewalls or codecs
(because the issue seems to be a quite rare one).

[url]How to find components causing high CPU usage]

Or does the problem only happen when Opus shows a particular folder?

Try creating an empty folder on your desktop, then double-clicking that to open it in Opus. Do you still see the problem?

(If Opus isn't set to replace Explorer, right-click the folder and use the Open in Directory Opus option, assuming that isn't also turned off.)

Could you post a screenshot showing what the window looks like when it is locked up?

This sounds a bit like the disease that recently afflicted me:

Directory Opus Resource Centre • View topic - Delays with PaperPort Anywhere cloud connector

Next time it happens, double click the desktop, or do whatever else you do to launch another occurrence of DOpus. Does it work? Can you get beyond the current hung window?

In my case, when this happened, I did not have to kill the whole thing, or reboot, just the currently running DOpus.exe.

The number of these events has dropped significantly since I stopped launching PaperPort Anywhere at boot.

I suspect something strange going on as the tree builds that is related to the attempts to connect to cloud stuff. I never did pin it down, even after starting to work, my way through the "General slowdown or instability investigation steps".

The puzzle for me was that even after the first hang, I could keep going with DOpus. Then again, I sometimes ended up with a set of DOpus windows that looked just like those you described, "folder tree showing contents but nothing in the file tab window". In other words, tree OK but nothing on the right.

Have you ventured into the cloud?

Thanks for the reply and suggestions. I am thinking perhaps a 3rd party problem. It happens randomly on different folders. When it happens I cannot get DOpus to respond to anything. Killing the process as well as the services does not help either. Double clicking on the desktop either produces no response from DOpus or it opens with the same window with the tree in tact but nothing on the right. The only way I can get it up and running again is a reboot. I will get a screenshot as soon as it happens again and post.

Well it has just happened again!!! :cry: :cry: :cry:

(Click for full-size image.)

BTW This is my normal window when DOpus is behaving.

(Click for full-size image.)

What is that Photo Stream folder in the folder tree related to?

This is what comes up when it is clicked on. I didn't think it was a problem because it is not active.

(Click for full-size image.)


Try using ShellExView to disable all shell extensions, except the Microsoft and Opus ones, and after doing so fully exit Opus and then re-launch it.

I would start with the iCloud / Photo Stream shell extension(s) as it/they may be the cause of the problem even though they are "inactive". (It can't be fully inactive as if it was it would not appear in the tree at all.)

Another thing I suggest is removing all of your tabs (in case the problem is triggered by a particular file or folder) and opening Opus to show an empty folder (or at least not any folders containing video files, which are often triggers for bugs in third-party video codecs which Opus will call into to get details about video files). (Avoid the DropBox folder as well; the DropBox shell extension has been known to trigger problems in the past, although they've usually been solved by updating it.)

Thanks for the prompt reply.
Will try your suggestions and post results.

I agree with Leo, given that my problems are much less when I disabled one of my cloud services.

Hopefully SOLVED!! I followed Leo's and Michael's suggestions and disabled shell extensions that referred to iCloud and DropBox as well as some other suspect ones and I am happy to report I have been problem free since.
Many thanks to this forum and particularly Leo and Michael for responding. Previously I had spent many hours searching the Internet without answers. I can happily now go back to enjoying DOpus.
Thanks again.

If you want to try narrowing it down, reinstate Dropbox.

I have that working here and rarely see that issue now.

I don't have iCloud. Maybe that is the guilty party. I always like to find excuses to beat up on Apple.

I think iCloud was the problem as I did reinstate Dropbox and have not had issues.

Interesting. In my case the culprit seems to have been PaperPort Anywhere, which comes from OfficeDrop via Nuance.

I haven't tried the OfficeDrop's own version. Maybe I will give it as go.

Far be it for me to cause anyone any work, but two cases of people with Opus getting lost in the clouds might be worth investigating to see what is going on under the bonnet. Ruling out some subtle interaction within Opus would then throw it back on the people who bring us these cloud services.

Unfortunately, I wouldn't know where to begin.

[quote="leo"]Or does the problem only happen when Opus shows a particular folder?

Try creating an empty folder on your desktop, then double-clicking that to open it in Opus. Do you still see the problem?[/quote]


If there is no freeze when you view an empty directory, please see Crash, exit or high CPU usage when viewing certain directories for suggestions on tracking down the cause of the problem.