GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Help not rendering in Firefox


#1

The help site is no longer rendering in Firefox 55.0.3 32 bit
https://www.gpsoft.com.au/help/opus12/index.html


#2

Works OK in Chrome, and it hasn't changed recently, so if it's just started being a problem I'd say that's likely to be caused by a Firefox update (or something unrelated, like a temporary outage, network problems, etc.)


#3

Absolutely fine here with Firefox 55.0.3 64 bit


#4

Interesting @auden, I'm using Firefox 55.0.3 32 bit. I tested on two different PC, with two different internet connections.


#5

Have you tried disabling all your Firefox extensions? That's where I would start. I have had lots of problems with extensions in the past.


#6

For whatever it's worth, OK here with Firefox 55.0.3 32-bit.


#7

Thanks @auden and @rcoleman1943.
It appears to be caused by UBlock Origin. Interestingly, the help site has worked for years with this add-on, and I have UBlock disabled for that site.

I will see if I can narrow down exactly what the cause is.


#8

The site is blank for me. Also on Firefox 55 with uBlock.


#9

ACK: https://github.com/gorhill/uBlock/releases/tag/1.14.6


#10

nice find. I only have four firefox add-ons. Three are legacy. If I disable them the page does not render. If I disable UBlock Origin it does. However reading that page it seems he is saying its an issue caused by a legacy add-on when used in with UBlock Origin.


#11

Firefox 55.03 x64:

Uninstalling uBlock makes no difference for me; still no manual. Disabling all ad-ons works; will have to see if it is a particular add-on...

Edit: After testing, issue occurs with uBlock Origin and/or Privacy Badger enabled. Both are ofMozilla's new WebExtensions variety.


#12

The blank page is not cause by JavaScript being disabled. If JavaScript is disabled you get the message "The content is not shown because JavaScript is disabled.".

This on the other hand renders a completely blank page. It seems that a recent change to Firefox is not compatible with the site with some addons.


#13

This appears to have been resolved. Using FireFox 57.0 I am able to see the help again.