How do I disable the auto shortcut feature?

New to Opus and it's great! But ... I need to disable the random creation of shortcuts to folders. There're just too many, none are wanted. Please advise and thanks!

Which shortcuts do you mean?

image Here's an example ...
I didn't create this link to my downloads folder, the prog did ... have multiples in my picture folder to sub folders too :ugh::

Opus doesn't create shortcuts like that, unless you explicitly tell it to.

What makes you think Opus made them?

Whoa, that's weird because I never create shortcuts - and they began to appear after installing Opus ..

If you want to hide them globally, add them as shown below.

Or to hide them ad hoc create a button with the following code:

set QUICKFILTER ~.lnk

Thanks BlueRoly ... going to try this out this moment!!

1 Like

Going to give a bit of time to see how things go but looks good so far - thank you!!
:smile:

1 Like

I don't think hiding all shortcuts globally is a good idea. There are times when you will need to see some.

Better to work out what triggers their creation and stop it happening, or at least only hide them in the particular folder they are being made in.

It could be accidental drag and drop. I do it semi frequently. If you double click and move the mouse during that it can happen (one of the clicks becomes a click and drag).
Can happen in the Lister or in the address bar.
There was a fix to stop it in the address bar.

Preventing a shortcut to a folder/file being made in the same Folder seems like a logical improvement. I don't think we can intercept the event with scripting.

1 Like

I concur. I use the button option to toggle them on/off.

Why do you have so many shortcuts that a button like that is necessary?

(and no, Opus doesn't auto-create them :slight_smile: )

In my case, the servers in work are full of them. See image below. When you hit the 'create shortcut' button Windows Explorer (which 99.9% of staff use) will create the shortcut in the current folder, which in my opinion, is stupid. If I delete them, they will appear again in a matter of weeks.

How odd :slight_smile:

I work with many odd people :slight_smile:

3 Likes

I have also encountered this issue. I believe it is caused by clicking on a folder in the path bar at the top of the Lister and then fractionally moving the mouse before releasing the mouse click - as if to slightly drag the folder name. A notification immediately appears that a shortcut will be created. When trying to navigate at speed, this unintentional action is easily done. It would be great if this feature could be disabled for all the inaccurate clickers like me!. If you spot it in time it can also be cancelled by pressing the ESC key before releasing the mouse click.

1 Like

You can prevent that with the dragignoreself option:

https://www.gpsoft.com.au/help/opus12/index.html#!Documents/Breadcrumbs_Configuration.htm

1 Like

Great! Many thanks.