How do I remove the Home / Quick Access folders from folder tree? (Win 11 22H2)

Before you ask, YES, I've unchecked the "Quick access" option until Folder Tree > Contents.

I recently moved from a Win 10 machine to Win 11. When I did this, I exported out my old DO config and imported it on my new PC. Everything seems fine, except... At some point I happened to notice new items in my folder tree (a Home folder, plus additional folders), all duplicated and triplicated from what I already have in my profile folder:

image

I finally figured out this junk might be something coming from Windows, not Opus. I thought turning off the "Quick access" was enough (it is in Win10), but using Win11 I'm getting all this extra stuff.

Using Explorer, I removed all the pinned items in the Home and it A) made Explorer even more useless than it already is, and B) did not help with removing the Home icon in DO or removing all the triplicated folders underneath it. As I mentioned before, this exact config on a Win10 machine doesn't do this, so I'm assuming this is some Win11 nonsense that DO is inheriting.

Can someone please let me know how I can get rid of "Home", plus the duplicated/triplicated Desktop, Documents, etc. folders that appear under it?

Are you using the current version of Opus and Win11 on that machine?

It looks like the Quick Access (now called Home for some reason) part of the tree has been duplicated under the Desktop branch. That isn't what I see here FWIW; it only appears as its own branch at the top, if turned on:

Things can be added to the Folder Tree in Windows via the registry, which might be where it's coming from.

It's done under:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace

And the same location under HKEY_LOCAL_MACHINE:

Bit painful to compare one system vs another, but that's a list of what's in the registry on my Win 11 test machine (which doesn't have much installed). If you click each large number, you can see the name of what it represents on the right.

It might also be worth making sure Opus isn't set to run in compatibility mode for a previous version of Windows, as that could mess up version-specific things which the Opus folder tree does to workaround Microsoft's changes in different versions:

Update: I was already on 22H2 but installed a few Windows Updates while typing that, and now I'm seeing the same thing. Microsoft must have just made a change to Windows 11 to do this for some reason.

File Explorer now shows exactly the same tree, if you turn on its "Show all folders" option (otherwise it doesn't really display a folder tree at all, just a few top-level shortcuts):

So this is apparently Microsoft's fantastic new standard for the tree in Windows 11. :slight_smile:

We plan to make the tree a lot more configurable in a future version, which should help here. In the short term, I am not sure if there is a way to suppress it. Knowing Microsoft, they'll change it back or to something else in a few weeks, if we're lucky.

1 Like

As if we needed another reason to despise Windows Explorer, LOL.

Thanks very much for checking, I was worried I was the only one seeing this. I look forward to the future fix for yet another Win11 annoyance.

1 Like