Kaspersky + XP SP3 freezes

Not sure whats going on , but when running Dopus in SP3 it just stops after exiting a lister. The whole window will do nothing, exit from dopus by right-clicking tray icon and exiting then everything ok.

Any ideas anyone ?

Works fine in XP SP3 for me and other people here.

Does it matter what you do before closing the window? Does it matter which folder(s) you view in the window before closing it, or whether or not you right-click particular files/folders or anything like that? Is the viewer on? Are you in Thumbnails or Tiles modes?

Details mode, double click on screen, lister opens, but cannot be moved or dragged. Files/Folders inside the lister can be selected and used as normal.

So the problem happens before closing the window? From the first post it sounded like it happened after closing it.

So you can use the file display and toolbars in the window, but the window border doesn't let you move the window. Can it be resized? Does it think it's maximized when it isn't, or something like that? Are you using anything that modifies the look or behaviour of window borders?

Cannot be resized and its a clean install, with no additional rubbish.
Got me really confused this one.

It is odd. What's Opus configured to do when you double-click the screen? If it's opening the Default Lister or a Lister Layout then it might be worth resetting your layouts.

To do this, first find out where your Opus config is stored by typing /dopusdata into the Location field in an Opus window.

Open that path in Explorer and exit Opus. (Kill dopus.exe using task manager if exiting via the tray icon isn't working.)

Now in Explorer, rename the Layouts folder to something else, then start Opus again.

If that fixes it, please zip up the old Layouts folder and attach it to a reply here. If it doesn't fix it you can rename the Layouts folder back so you haven't lost anything.

Gimme 10 min, will try it.

No joy, exactly the same

I can't think of anything else to try I'm afraid. If nobody else at the forum has any ideas you should contact GPSoftware for support to see if they can track down the problem. Very strange indeed, and not something I've heard of before, so I don't know what else to try.

Maybe a screenshot of the lister would be worth posting, just in case there is any kind of visual clue about what's going on.

Solved the problem, its Kaspersky 2009 antivirus. Dont know why but it does not like Dopus. Clean install without Kaspersky and everything is perfect, install Kaspersky and Dopus goes haywire.
Thanks for your help and hope this also helps others...

Thanks for letting us know. Might help other peolpe with the same problem.

Have you let Kaspersky know about the problem so they can investigate/fix it?

I did a quick search of their forums and found a post from February which said Kaspersky and Opus had problems but a later reply said that the poster solved the problem by uninstalling some other anti-virus/spyware software. Sounds like he had a lot of real-time scanning software installed at once so it was not surprising that Opus (and other things I would assume) was slowed down. (Especially if a column like Description is shown since that causes Opus to open every file to get information about it. It several A/V scanners then scan every file that can cause quite a burden. Good A/V scanners try to avoid scanning files they have already scanned which helps there.)

Sent a message to Kaspersky support, no reply yet. Will let you know what they say when they reply.

Many thanks!

I'm confirming this problem as following:

XP SP3 + Kaspersky Antivirus 7 + Directory Opus 9 ----> No Problem
XP SP3 + Kaspersky Antivirus 8 + Directory Opus 9 ----> CPU usage of Directory Opus is very very high and Dopus responses very very slowly as if it is frozen (in fact not, it responses after some time)

I'm sure that the reason is not SP3 and I'm sure that the problem cannot be solved with some Kaspersky settings. Because even after closing and/or disabling Kaspersky from tray menu, Dopus stills responses slowly.


I went back to McAFee which was supplied by my ISP and no problems. Kaspersky have still not replied so dont know if this is being looked at or not.
Have to say that McAFee is far better than I thought and works perfectly with Dopus 9.

No problems using NOD32 + Opus on two machines here, either. It definitely seems like a bug in Kaspersky to me.

Just sent another email to Kaspersky to remind them of the problem.

XP SP3 Final is still Beta (in my opinion) and doesn't have the quality of SP2.

Have the EXACT same problem. Clean install of XP w/SP3, Kaspersky 2009 and DOPus 9.1 (both registered) and freezes. I can't switch to another AV as i have already paid for a year of Kaspersky. I have no other scanning software and no problems with other programs. I even have kaspersky paused and the issue persists.

What gives?

Send Kaspersky an email or go to the support page on there site. Maybe if enough users report it they may do something about it.