Literal printout of HTML code in Help

I'm not sure what happened, but when I try to look up a topic in DO's Help menu, I see a literal printout of the HTML contents in the right pane of the Help window (exactly as shown below). Does DO use IE's rendering engine for HTML? I'm runing DO under WinXP SP3. I normally use Firefox, but I have IE7 installed, in case some app needs its engine.

[code]<?xml version="1.0" encoding="Windows-1252" ?>

  • Welcome to Directory Opus
  • [/code]

Opus uses Microsoft's HTMLHelp system to display the online help. That in turn does use IE's rendering engine.

I would try the suggestions on this page about repairing HTMLHelp, starting with this one:

[quote]2: Content (Style Sheet / images) not rendered correctly in help viewer

Try emptying your Temporary Files Cache (Control Panel > Internet Options > General page > Delete Files...). When the cache fills up IE cannot render its content correctly.[/quote]

If that doesn't work I would try checking for any IE updates on Windows Update and then try reinstalling HTMLHelp using the links in the article I linked above, under the First check - Do you have the Latest Help Runtime Files? section.

Thanks for the tips, but they didn't help. As a test, I used HTML Help to view .chm files in Windows\Help directory. They look fine. However, I think their content is plain HTML, whereas DOpus's help (Dopus.chm) is XML. I suspect that the problem is XML-related and may have something to do with the MSXML Parser component that got installed on my machine along with Visual Studio.

Are you able to view the test.html file inside the attached zip in Internet Explorer?

It was made by saving one of the pages from the help file. It starts with the XML identifier but views fine here (except for the broken images since they were not saved). So if that doesn't work in IE on your system then you know what to concentrate on.

Maybe you can repair IE or re-register (with regsvr32.exe) the various MSXML*.DLL files in your system32 directory. (Different versions of MSXML can coexist side-by-side so registering all of them should be fine. Some apps/components use different versions of the DLL so you can't just keep/register the latest version.) (3.04 KB)

Vista 64-bit, AMD dual-core 64-bit processor

I just installed and have the same problem. Tried all the above and no luck. The weird thing is that it's only Dopus that's displaying xml code - all other .chm files are fine and they're all opening as Microsoft HTML Help Executables.

I'm going to try out some of the MJ Diagnostics but not hopeful since a known issue is that they don't work in Vista 64.

Any other suggestions, i.e., converting the code, maybe compiling what's there?

Since this is only happening with DOpus, I've gotta think it's :arrow_right: youse guys what made the boo-boo! But I still think you're great.

Could you try the test and suggestions in Leo's message posted above?

I did. As I mentioned, it's only Dopus where this is happening.

So you tried the that Leo attached and got the same result?

And you tried re-registering the msxml files as he suggested?


I have this same problem but I can see the test file.

I also emptied the temporary internet files.

What can be done?